summaryrefslogtreecommitdiff
path: root/installer.nix
diff options
context:
space:
mode:
Diffstat (limited to 'installer.nix')
-rw-r--r--installer.nix18
1 files changed, 14 insertions, 4 deletions
diff --git a/installer.nix b/installer.nix
index 3bdca7ab..9276907f 100644
--- a/installer.nix
+++ b/installer.nix
@@ -8,13 +8,11 @@
8 8
9 boot.kernelPackages = pkgs.linuxPackages_latest; 9 boot.kernelPackages = pkgs.linuxPackages_latest;
10 10
11 systemd.services.sshd.wantedBy = lib.mkForce [ "multi-user.target" ];
12
13 environment.systemPackages = with pkgs; [ 11 environment.systemPackages = with pkgs; [
14 mosh 12 mosh
15 tmux 13 tmux
16 zsh 14 zsh
17 pythonPackages.magic-wormhole 15 python3Packages.magic-wormhole
18 ]; 16 ];
19 17
20 networking = { 18 networking = {
@@ -30,5 +28,17 @@
30 }; 28 };
31 }; 29 };
32 30
33 i18n.consoleKeyMap = "dvp"; 31 users.users.root =
32 let template = import ./users/gkleen.nix;
33 in {
34 inherit (template) shell;
35 openssh.authorizedKeys.keyFiles = template.openssh.authorizedKeys.keyFiles;
36 };
37
38 services.openssh = {
39 enable = true;
40 passwordAuthentication = false;
41 };
42
43 console.keyMap = "dvp";
34} 44}