summaryrefslogtreecommitdiff
path: root/hosts/vidhar/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/vidhar/default.nix')
-rw-r--r--hosts/vidhar/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/hosts/vidhar/default.nix b/hosts/vidhar/default.nix
index 0bb1f680..6002947f 100644
--- a/hosts/vidhar/default.nix
+++ b/hosts/vidhar/default.nix
@@ -155,5 +155,35 @@
155 sopsFile = ./grafana-secret-key; 155 sopsFile = ./grafana-secret-key;
156 owner = "grafana"; 156 owner = "grafana";
157 }; 157 };
158
159 services.loki = {
160 enable = true;
161 configuration = {
162 auth_enabled = false;
163 server = {
164 http_listen_port = 9094;
165 grpc_listen_port = 9095;
166 };
167 };
168 };
169 services.promtail = {
170 enable = true;
171 configuration = {
172 server = {
173 http_listen_port = 9080;
174 grpc_listen_port = 0;
175 };
176 clients = [
177 { url = "http://localhost:9094/loki/api/v1/push"; }
178 ];
179 scrape_configs = [
180 { job_name = "system";
181 journal = {
182 json = true;
183 };
184 }
185 ];
186 };
187 };
158 }; 188 };
159} 189}