diff options
Diffstat (limited to 'hel.nix')
-rw-r--r-- | hel.nix | 10 |
1 files changed, 5 insertions, 5 deletions
@@ -106,8 +106,8 @@ | |||
106 | ''; | 106 | ''; |
107 | }); | 107 | }); |
108 | 108 | ||
109 | fprintd = pkgs.stdenv.mkDerivation rec { | 109 | libfprint = pkgs.stdenv.mkDerivation rec { |
110 | name = "fprintd-${version}"; | 110 | name = "libfprint-${version}"; |
111 | version = "vfs0090-f8323a0"; | 111 | version = "vfs0090-f8323a0"; |
112 | 112 | ||
113 | src = pkgs.fetchFromGitHub { | 113 | src = pkgs.fetchFromGitHub { |
@@ -117,14 +117,14 @@ | |||
117 | sha256 = "0y0lkwgw1lx4frm1kxz0hj11x93dby7vxkjly0ck7w7z96nn8bnm"; | 117 | sha256 = "0y0lkwgw1lx4frm1kxz0hj11x93dby7vxkjly0ck7w7z96nn8bnm"; |
118 | }; | 118 | }; |
119 | 119 | ||
120 | buildInputs = with pkgs; [ libfprint glib dbus-glib polkit nss pam systemd libusb1 ]; | 120 | buildInputs = with pkgs; [ libusb pixman glib nss nspr gdk_pixbuf ]; |
121 | nativeBuildInputs = with pkgs; [ pkgconfig intltool libtool automake autoconf ]; | 121 | nativeBuildInputs = with pkgs; [ pkgconfig libtool automake autoconf ]; |
122 | 122 | ||
123 | preConfigure = '' | 123 | preConfigure = '' |
124 | NOCONFIGURE=true ./autogen.sh | 124 | NOCONFIGURE=true ./autogen.sh |
125 | ''; | 125 | ''; |
126 | 126 | ||
127 | configureFlags = [ "--with-systemdsystemunitdir=$(out)/lib/systemd/system" ]; | 127 | configureFlags = [ "--with-udev-rules-dir=$(out)/lib/udev/rules.d" ]; |
128 | }; | 128 | }; |
129 | }; | 129 | }; |
130 | 130 | ||