diff options
Diffstat (limited to 'hel.nix')
-rw-r--r-- | hel.nix | 59 |
1 files changed, 49 insertions, 10 deletions
@@ -19,19 +19,23 @@ | |||
19 | 19 | ||
20 | networking = { | 20 | networking = { |
21 | hostName = "hel"; | 21 | hostName = "hel"; |
22 | wireless = { | 22 | # wireless = { |
23 | enable = true; | 23 | # enable = true; |
24 | userControlled = { | 24 | # userControlled = { |
25 | enable = true; | 25 | # enable = true; |
26 | group = "network"; | 26 | # group = "network"; |
27 | }; | 27 | # }; |
28 | }; | 28 | # }; |
29 | 29 | ||
30 | firewall = { | 30 | firewall = { |
31 | enable = true; | 31 | enable = true; |
32 | allowedTCPPorts = [ 22 # ssh | 32 | allowedTCPPorts = [ 22 # ssh |
33 | ]; | 33 | ]; |
34 | }; | 34 | }; |
35 | |||
36 | networkmanager = { | ||
37 | enable = true; | ||
38 | }; | ||
35 | }; | 39 | }; |
36 | 40 | ||
37 | powerManagement.enable = true; | 41 | powerManagement.enable = true; |
@@ -50,8 +54,20 @@ | |||
50 | shadow | 54 | shadow |
51 | (callPackage ./custom/thinklight.nix { thinklight = "kbd_backlight"; }) | 55 | (callPackage ./custom/thinklight.nix { thinklight = "kbd_backlight"; }) |
52 | (callPackage ./utils/nix/rebuild-system.nix {}) | 56 | (callPackage ./utils/nix/rebuild-system.nix {}) |
57 | libmbim libqmi | ||
53 | ]; | 58 | ]; |
54 | 59 | ||
60 | nixpkgs.config.packageOverrides = pkgs: rec { | ||
61 | libmbim = pkgs.stdenv.lib.overrideDerivation pkgs.libmbim (attrs: { | ||
62 | patches = [ ./patches/attachment-0003.patch ./patches/attachment.patch ]; | ||
63 | buildInputs = attrs.buildInputs ++ [ pkgs.automake114x pkgs.autoconf ]; | ||
64 | }); | ||
65 | libqmi = pkgs.stdenv.lib.overrideDerivation pkgs.libqmi (attrs: { | ||
66 | patches = [ ./patches/attachment-0004.patch ./patches/attachment-0005.patch ]; | ||
67 | buildInputs = attrs.buildInputs ++ [ pkgs.automake pkgs.autoconf ]; | ||
68 | }); | ||
69 | }; | ||
70 | |||
55 | services = { | 71 | services = { |
56 | logind.extraConfig = '' | 72 | logind.extraConfig = '' |
57 | HandleLidSwitch=suspend | 73 | HandleLidSwitch=suspend |
@@ -107,8 +123,8 @@ | |||
107 | nodeName = "hel"; | 123 | nodeName = "hel"; |
108 | remoteNodes = ["isaac" "ymir"]; # legacy name for odin | 124 | remoteNodes = ["isaac" "ymir"]; # legacy name for odin |
109 | sshUser = { | 125 | sshUser = { |
110 | openssh.authorizedKeys.keys = [ ''no-port-forwarding,no-X11-forwarding,no-agent-forwarding,command="/var/setuid-wrappers/uucico" ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIEgtDHA7oDIaRwggGGznNaKZF68rFTziqefSCn1t9ZKe uucp@odin'' | 126 | openssh.authorizedKeys.keys = [ ''no-port-forwarding,no-X11-forwarding,no-agent-forwarding,command="/var/setuid-wrappers/uucico" ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIFH1QWdgoC03nzW5GBuCl2pqASHeIXIYtE9IInHdaKcO uucp@ymir'' |
111 | ''no-port-forwarding,no-X11-forwarding,no-agent-forwarding,command="/var/setuid-wrappers/uucico" ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIFH1QWdgoC03nzW5GBuCl2pqASHeIXIYtE9IInHdaKcO uucp@ymir'' | 127 | ''no-port-forwarding,no-X11-forwarding,no-agent-forwarding,command="/var/setuid-wrappers/uucico" ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIJhACtnt9+3j2ev4QVA2QBlPtblPnu7yol2njgfMlHtC uucp@odin'' |
112 | ]; | 128 | ]; |
113 | }; | 129 | }; |
114 | sshConfig = '' | 130 | sshConfig = '' |
@@ -119,8 +135,28 @@ | |||
119 | Hostname ymir.niflheim.yggdrasil | 135 | Hostname ymir.niflheim.yggdrasil |
120 | IdentityFile ~/.ssh/ymir | 136 | IdentityFile ~/.ssh/ymir |
121 | ''; | 137 | ''; |
122 | commandPath = []; | 138 | commandPath = [ "${pkgs.callPackage ./hel/recv-media.nix {}}/bin" ]; |
123 | defaultCommands = []; | 139 | defaultCommands = []; |
140 | commands = { | ||
141 | "isaac" = ["recv-media"]; | ||
142 | }; | ||
143 | }; | ||
144 | |||
145 | postfix = { | ||
146 | enable = true; | ||
147 | enableSmtp = false; | ||
148 | setSendmail = true; | ||
149 | networksStyle = "host"; | ||
150 | hostname = "hel.midgard.yggdrasil"; | ||
151 | destination = []; | ||
152 | relayHost = "uucp:ymir"; | ||
153 | recipientDelimiter = "+"; | ||
154 | transport = '' | ||
155 | * uucp:ymir | ||
156 | ''; | ||
157 | extraMasterConf = '' | ||
158 | uucp unix - n n - - pipe flags=Fqhu user=uucp argv=/var/setuid-wrappers/uux -z -a$sender - $nexthop!rmail ($recipient) | ||
159 | ''; | ||
124 | }; | 160 | }; |
125 | }; | 161 | }; |
126 | 162 | ||
@@ -134,6 +170,9 @@ | |||
134 | media = { | 170 | media = { |
135 | members = [ "gkleen" "uucp" ]; | 171 | members = [ "gkleen" "uucp" ]; |
136 | }; | 172 | }; |
173 | networkmanager = { | ||
174 | members = [ "gkleen" ]; | ||
175 | }; | ||
137 | }; | 176 | }; |
138 | }; | 177 | }; |
139 | 178 | ||