diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 11 |
1 files changed, 6 insertions, 5 deletions
@@ -135,7 +135,7 @@ | |||
135 | 135 | ||
136 | packages = | 136 | packages = |
137 | let installerPackages = system: optionalAttrs (!(isNull installerConfig)) (mapAttrs' (profile: value: nameValuePair "installer-${profile}" value.output) installers.${system}); | 137 | let installerPackages = system: optionalAttrs (!(isNull installerConfig)) (mapAttrs' (profile: value: nameValuePair "installer-${profile}" value.output) installers.${system}); |
138 | in forAllSystems (system: systemPkgs: self.overlay (self.legacyPackages.${system}) systemPkgs // installerPackages system); | 138 | in forAllSystems (system: systemPkgs: self.overlays.default (self.legacyPackages.${system}) systemPkgs // installerPackages system); |
139 | in | 139 | in |
140 | { | 140 | { |
141 | nixosModules = | 141 | nixosModules = |
@@ -151,8 +151,9 @@ | |||
151 | homeModules = nixImport rec { dir = ./home-modules; }; | 151 | homeModules = nixImport rec { dir = ./home-modules; }; |
152 | homeConfigurations = listToAttrs (concatLists (mapAttrsToList (hostname: nixosConfig: mapAttrsToList (username: configuration: nameValuePair "${username}@${hostname}" { inherit (configuration.home) activationPackage; }) nixosConfig.config.home-manager.users) self.nixosConfigurations)); | 152 | homeConfigurations = listToAttrs (concatLists (mapAttrsToList (hostname: nixosConfig: mapAttrsToList (username: configuration: nameValuePair "${username}@${hostname}" { inherit (configuration.home) activationPackage; }) nixosConfig.config.home-manager.users) self.nixosConfigurations)); |
153 | 153 | ||
154 | overlay = final: prev: composeManyExtensions (attrValues self.overlays) final prev; | 154 | overlays = let |
155 | overlays = mapAttrs (_name: path: import path) overlayPaths; | 155 | overlays = mapAttrs (_name: path: import path) overlayPaths; |
156 | in overlays // { default = final: prev: composeManyExtensions (attrValues overlays) final prev; }; | ||
156 | overlays-path = forAllSystems (system: _: self.legacyPackages.${system}.writeText "overlays.nix" '' | 157 | overlays-path = forAllSystems (system: _: self.legacyPackages.${system}.writeText "overlays.nix" '' |
157 | map import (builtins.attrValues (builtins.fromJSON ${self.legacyPackages.${system}.lib.strings.escapeNixString (toJSON overlayPaths)})) | 158 | map import (builtins.attrValues (builtins.fromJSON ${self.legacyPackages.${system}.lib.strings.escapeNixString (toJSON overlayPaths)})) |
158 | ''); | 159 | ''); |
@@ -164,9 +165,9 @@ | |||
164 | 165 | ||
165 | apps = activateNixosConfigurations; | 166 | apps = activateNixosConfigurations; |
166 | 167 | ||
167 | devShell = forAllSystems (system: systemPkgs: import ./shell.nix { pkgs = self.legacyPackages.${system}; deploy-rs = deploy-rs.defaultPackage.${system}; }); | 168 | devShells = forAllSystems (system: systemPkgs: { default = import ./shell.nix { pkgs = self.legacyPackages.${system}; deploy-rs = deploy-rs.defaultPackage.${system}; }; }); |
168 | 169 | ||
169 | defaultTemplate = { | 170 | templates.default = { |
170 | path = ./.; | 171 | path = ./.; |
171 | description = "GKleen's flakey nixos configuration"; | 172 | description = "GKleen's flakey nixos configuration"; |
172 | }; | 173 | }; |