diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 7 |
1 files changed, 4 insertions, 3 deletions
@@ -45,6 +45,7 @@ | |||
45 | utils = import ./utils { inherit lib; }; | 45 | utils = import ./utils { inherit lib; }; |
46 | inherit (utils) nixImport overrideModule; | 46 | inherit (utils) nixImport overrideModule; |
47 | inherit (lib) nixosSystem mkIf splitString filterAttrs listToAttrs mapAttrsToList nameValuePair concatMap composeManyExtensions mapAttrs mapAttrs' recursiveUpdate genAttrs unique elem optionalAttrs isDerivation concatLists concatStringsSep; | 47 | inherit (lib) nixosSystem mkIf splitString filterAttrs listToAttrs mapAttrsToList nameValuePair concatMap composeManyExtensions mapAttrs mapAttrs' recursiveUpdate genAttrs unique elem optionalAttrs isDerivation concatLists concatStringsSep; |
48 | inherit (lib.strings) escapeNixString; | ||
48 | 49 | ||
49 | accountUserName = accountName: | 50 | accountUserName = accountName: |
50 | let | 51 | let |
@@ -165,9 +166,9 @@ | |||
165 | homeConfigurations = listToAttrs (concatLists (mapAttrsToList (hostname: nixosConfig: mapAttrsToList (username: configuration: nameValuePair "${username}@${hostname}" { inherit (configuration.home) activationPackage; }) nixosConfig.config.home-manager.users) self.nixosConfigurations)); | 166 | homeConfigurations = listToAttrs (concatLists (mapAttrsToList (hostname: nixosConfig: mapAttrsToList (username: configuration: nameValuePair "${username}@${hostname}" { inherit (configuration.home) activationPackage; }) nixosConfig.config.home-manager.users) self.nixosConfigurations)); |
166 | 167 | ||
167 | overlays = mapAttrs (_name: path: mkOverlay path) overlayPaths; | 168 | overlays = mapAttrs (_name: path: mkOverlay path) overlayPaths; |
168 | overlays-path = forAllSystems (system: _: self.legacyPackages.${system}.writeText "overlays.nix" '' | 169 | overlays-path = forAllSystems (system: systemPkgs: toString (systemPkgs.writeText "overlays.nix" '' |
169 | map import (builtins.attrValues (builtins.fromJSON ${self.legacyPackages.${system}.lib.strings.escapeNixString (toJSON overlayPaths)})) | 170 | map import (builtins.attrValues (builtins.fromJSON ${escapeNixString (toJSON overlayPaths)})) |
170 | ''); | 171 | '')); |
171 | 172 | ||
172 | packages = mapAttrs (_name: filterAttrs (_name: isDerivation)) packages; | 173 | packages = mapAttrs (_name: filterAttrs (_name: isDerivation)) packages; |
173 | packages' = mapAttrs (_name: filterAttrs (_name: value: !(isDerivation value))) packages; | 174 | packages' = mapAttrs (_name: filterAttrs (_name: value: !(isDerivation value))) packages; |