diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 7 |
1 files changed, 3 insertions, 4 deletions
@@ -14,7 +14,6 @@ | |||
14 | repo = "home-manager"; | 14 | repo = "home-manager"; |
15 | ref = "master"; | 15 | ref = "master"; |
16 | inputs = { | 16 | inputs = { |
17 | flake-compat.follows = "flake-compat"; | ||
18 | nixpkgs.follows = "nixpkgs"; | 17 | nixpkgs.follows = "nixpkgs"; |
19 | }; | 18 | }; |
20 | }; | 19 | }; |
@@ -78,11 +77,11 @@ | |||
78 | inherit (lib) nixosSystem mkIf splitString filterAttrs listToAttrs mapAttrsToList nameValuePair concatMap composeManyExtensions mapAttrs mapAttrs' recursiveUpdate genAttrs unique elem optionalAttrs isDerivation concatLists concatStringsSep fix filter makeOverridable foldr; | 77 | inherit (lib) nixosSystem mkIf splitString filterAttrs listToAttrs mapAttrsToList nameValuePair concatMap composeManyExtensions mapAttrs mapAttrs' recursiveUpdate genAttrs unique elem optionalAttrs isDerivation concatLists concatStringsSep fix filter makeOverridable foldr; |
79 | inherit (lib.strings) escapeNixString; | 78 | inherit (lib.strings) escapeNixString; |
80 | 79 | ||
81 | accountUserName = accountName: | 80 | accountUserName = accountName: |
82 | let | 81 | let |
83 | accountName' = splitString "@" accountName; | 82 | accountName' = splitString "@" accountName; |
84 | in elemAt accountName' 0; | 83 | in elemAt accountName' 0; |
85 | accountHostName = accountName: | 84 | accountHostName = accountName: |
86 | let | 85 | let |
87 | accountName' = splitString "@" accountName; | 86 | accountName' = splitString "@" accountName; |
88 | in elemAt accountName' 1; | 87 | in elemAt accountName' 1; |
@@ -132,7 +131,7 @@ | |||
132 | (outputs: { _file = dir + "/${path}"; } | 131 | (outputs: { _file = dir + "/${path}"; } |
133 | // outputs | 132 | // outputs |
134 | // { imports = defaultUserProfiles userName ++ (outputs.imports or []); }); | 133 | // { imports = defaultUserProfiles userName ++ (outputs.imports or []); }); |
135 | 134 | ||
136 | mkUserProfile = userName: dir: path: profileName: | 135 | mkUserProfile = userName: dir: path: profileName: |
137 | let | 136 | let |
138 | profileModule = overrideModule (import (dir + "/${path}")) | 137 | profileModule = overrideModule (import (dir + "/${path}")) |