summaryrefslogtreecommitdiff
path: root/customized/prosody.nix
diff options
context:
space:
mode:
Diffstat (limited to 'customized/prosody.nix')
-rw-r--r--customized/prosody.nix20
1 files changed, 10 insertions, 10 deletions
diff --git a/customized/prosody.nix b/customized/prosody.nix
index 87f88f4b..f8633742 100644
--- a/customized/prosody.nix
+++ b/customized/prosody.nix
@@ -1,11 +1,11 @@
1{ stdenv, fetchurl, libidn, openssl, makeWrapper, fetchhg 1{ stdenv, fetchurl, libidn, openssl, makeWrapper, fetchhg
2, lua5, luasocket, luasec, luaexpat, luafilesystem, luabitop, luaevent ? null, luazlib ? null 2, lua5, luasocket, luasec, luaexpat, luafilesystem, luabitop, luaevent ? null, luadbi ? null
3, withLibevent ? true, withZlib ? true 3, withLibevent ? true, withZlib ? true, withDBI ? true
4, withCommunityModules ? [], extraLibs ? [], extraModules ? [] 4, withCommunityModules ? [], extraLibs ? [], extraModules ? []
5}: 5}:
6 6
7assert withLibevent -> luaevent != null; 7assert withLibevent -> luaevent != null;
8assert withZlib -> luazlib != null; 8assert withDBI -> luadbi != null;
9 9
10with stdenv.lib; 10with stdenv.lib;
11 11
@@ -26,23 +26,23 @@ let
26in 26in
27 27
28stdenv.mkDerivation rec { 28stdenv.mkDerivation rec {
29 version = "0.9.12"; 29 version = "0.11.3";
30 name = "prosody-${version}"; 30 pname = "prosody";
31 31
32 src = fetchurl { 32 src = fetchurl {
33 url = "http://prosody.im/downloads/source/${name}.tar.gz"; 33 url = "http://prosody.im/downloads/source/${name}.tar.gz";
34 sha256 = "139yxqpinajl32ryrybvilh54ddb1q6s0ajjhlcs4a0rnwia6n8s"; 34 sha256 = "11xz4milv2962qf75vrdwsvd8sy2332nf69202rmvz5989pvvnng";
35 }; 35 };
36 36
37 communityModules = fetchhg { 37 communityModules = fetchhg {
38 url = "https://hg.prosody.im/prosody-modules/"; 38 url = "https://hg.prosody.im/prosody-modules/";
39 rev = "9b43b7fc3558"; 39 rev = "b54e98d5c4a1";
40 sha256 = "0rfn5hb1yhm8hs5xf3cx5szsvdvfx83a9d8zx6rdlpw54bwhkwbf"; 40 sha256 = "0bzn92j48krb2zhp9gn5bbn5sg0qv15j5lpxfszwqdln3lpmrvzg";
41 }; 41 };
42 42
43 buildInputs = [ lua5 luasocket luasec luaexpat luabitop libidn openssl makeWrapper ] 43 buildInputs = [ lua5 luasocket luasec luaexpat luabitop libidn openssl makeWrapper ]
44 ++ optional withLibevent luaevent 44 ++ optional withLibevent luaevent
45 ++ optional withZlib luazlib; 45 ++ optional withDBI luadbi;
46 46
47 configureFlags = [ 47 configureFlags = [
48 "--ostype=linux" 48 "--ostype=linux"
@@ -69,6 +69,6 @@ stdenv.mkDerivation rec {
69 license = licenses.mit; 69 license = licenses.mit;
70 homepage = http://www.prosody.im; 70 homepage = http://www.prosody.im;
71 platforms = platforms.linux; 71 platforms = platforms.linux;
72 maintainers = [ maintainers.flosse ]; 72 maintainers = [];
73 }; 73 };
74} 74}