summaryrefslogtreecommitdiff
path: root/customized/factorio-fetch.nix
diff options
context:
space:
mode:
Diffstat (limited to 'customized/factorio-fetch.nix')
-rw-r--r--customized/factorio-fetch.nix32
1 files changed, 0 insertions, 32 deletions
diff --git a/customized/factorio-fetch.nix b/customized/factorio-fetch.nix
deleted file mode 100644
index 4b9b9995..00000000
--- a/customized/factorio-fetch.nix
+++ /dev/null
@@ -1,32 +0,0 @@
1{ stdenv, curl, xidel, cacert
2# Begin download parameters
3, username ? ""
4, password ? ""
5}:
6
7{
8 # URL to fetch.
9 url ? ""
10
11 # Login URL.
12, loginUrl ? "https://www.factorio.com/login"
13
14 # SHA256 of the fetched URL.
15, sha256 ? ""
16, name
17}:
18
19stdenv.mkDerivation {
20 buildInputs = [ curl xidel ];
21
22 inherit name url loginUrl username password cacert;
23
24 builder = ./fetch.sh;
25
26 outputHashAlgo = "sha256";
27 outputHash = sha256;
28 outputHashMode = "flat";
29
30 # There's no point in downloading remotely, we'd just slow things down.
31 preferLocalBuild = true;
32}