summaryrefslogtreecommitdiff
path: root/customized/factorio-fetch.nix
diff options
context:
space:
mode:
authorGregor Kleen <pngwjpgh@users.noreply.github.com>2016-09-13 04:45:37 +0200
committerGregor Kleen <pngwjpgh@users.noreply.github.com>2016-09-13 04:45:37 +0200
commit7f0f97c06245b21a51210054e25fceab4b577cea (patch)
tree71d2b033d348f6741d417d1a3578c3b98b3c6925 /customized/factorio-fetch.nix
parent7b7ef4e9ba4d3c77bd874f4851f5165c06a27a5a (diff)
downloadnixos-7f0f97c06245b21a51210054e25fceab4b577cea.tar
nixos-7f0f97c06245b21a51210054e25fceab4b577cea.tar.gz
nixos-7f0f97c06245b21a51210054e25fceab4b577cea.tar.bz2
nixos-7f0f97c06245b21a51210054e25fceab4b577cea.tar.xz
nixos-7f0f97c06245b21a51210054e25fceab4b577cea.zip
simplify factorio again
Diffstat (limited to 'customized/factorio-fetch.nix')
-rw-r--r--customized/factorio-fetch.nix32
1 files changed, 0 insertions, 32 deletions
diff --git a/customized/factorio-fetch.nix b/customized/factorio-fetch.nix
deleted file mode 100644
index 4b9b9995..00000000
--- a/customized/factorio-fetch.nix
+++ /dev/null
@@ -1,32 +0,0 @@
1{ stdenv, curl, xidel, cacert
2# Begin download parameters
3, username ? ""
4, password ? ""
5}:
6
7{
8 # URL to fetch.
9 url ? ""
10
11 # Login URL.
12, loginUrl ? "https://www.factorio.com/login"
13
14 # SHA256 of the fetched URL.
15, sha256 ? ""
16, name
17}:
18
19stdenv.mkDerivation {
20 buildInputs = [ curl xidel ];
21
22 inherit name url loginUrl username password cacert;
23
24 builder = ./fetch.sh;
25
26 outputHashAlgo = "sha256";
27 outputHash = sha256;
28 outputHashMode = "flat";
29
30 # There's no point in downloading remotely, we'd just slow things down.
31 preferLocalBuild = true;
32}