summaryrefslogtreecommitdiff
path: root/custom/uucp.nix
diff options
context:
space:
mode:
Diffstat (limited to 'custom/uucp.nix')
-rw-r--r--custom/uucp.nix18
1 files changed, 17 insertions, 1 deletions
diff --git a/custom/uucp.nix b/custom/uucp.nix
index 39c2999c..602f95fd 100644
--- a/custom/uucp.nix
+++ b/custom/uucp.nix
@@ -170,6 +170,22 @@ in {
170 }); 170 });
171 }; 171 };
172 172
173 environment.systemPackages = with pkgs; [uucp]; 173 environment.systemPackages = with pkgs; [
174 uucp
175 (pkgs.writeScriptBin "rmail" ''
176 #!${pkgs.stdenv.shell}
177
178 # Dummy UUCP rmail command for postfix/qmail systems
179
180 IFS=" " read junk from junk junk junk junk junk junk junk relay
181
182 case "$from" in
183 *[@!]*) ;;
184 *) from="$from@$relay";;
185 esac
186
187 exec /var/setuid-wrappers/sendmail -i -f "$from" -- "$@"
188 '')
189 ];
174 }; 190 };
175} 191}