summaryrefslogtreecommitdiff
path: root/custom/uucp.nix
diff options
context:
space:
mode:
Diffstat (limited to 'custom/uucp.nix')
-rw-r--r--custom/uucp.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/custom/uucp.nix b/custom/uucp.nix
index e384f0b1..ea6f2eef 100644
--- a/custom/uucp.nix
+++ b/custom/uucp.nix
@@ -81,7 +81,7 @@ rec {
81 }; 81 };
82 }; 82 };
83 83
84 config = with config; { 84 config = {
85 environment.etc."uucp/config" = { 85 environment.etc."uucp/config" = {
86 enable = config.services.uucp.enable; 86 enable = config.services.uucp.enable;
87 text = '' 87 text = ''
@@ -96,11 +96,11 @@ rec {
96 ''; 96 '';
97 }; 97 };
98 98
99 users.users."uucp" = optional services.uucp.enable services.uucp.sshUser; 99 users.users."uucp" = optional config.services.uucp.enable config.services.uucp.sshUser;
100 100
101 system.activationScripts."uucp-sshconfig" = optional services.uucp.enable '' 101 system.activationScripts."uucp-sshconfig" = optional config.services.uucp.enable ''
102 mkdir -p ${users.users."uucp".home}/.ssh 102 mkdir -p ${config.users.users."uucp".home}/.ssh
103 cp ${builtins.toFile "ssh-config" services.uucp.sshConfig} ${users.users."uucp".home}/.ssh/config 103 cp ${builtins.toFile "ssh-config" config.services.uucp.sshConfig} ${config.users.users."uucp".home}/.ssh/config
104 ''; 104 '';
105 }; 105 };
106} 106}