summaryrefslogtreecommitdiff
path: root/custom/uucp.nix
diff options
context:
space:
mode:
Diffstat (limited to 'custom/uucp.nix')
-rw-r--r--custom/uucp.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/custom/uucp.nix b/custom/uucp.nix
index 2fbba8f9..0e38f4d2 100644
--- a/custom/uucp.nix
+++ b/custom/uucp.nix
@@ -208,7 +208,9 @@ in {
208 text = config.services.uucp.extraSys + "\n" + concatStringsSep "\n" (map sysSpec config.services.uucp.remoteNodes); 208 text = config.services.uucp.extraSys + "\n" + concatStringsSep "\n" (map sysSpec config.services.uucp.remoteNodes);
209 }; 209 };
210 210
211 security.wrappers = listToAttrs (map (p: {source = "${pkgs.uucp}/bin/${p}"; owner = "root"; group = "root"; setuid = true; setgid = false;}) ["uucico" "uuxqt" "cu" "uucp" "uuname" "uustat" "uux"]); 211 security.wrappers = let
212 wrapper = p: { name = p; source = "${pkgs.uucp}/bin/${p}"; owner = "root"; group = "root"; setuid = true; setgid = false; };
213 in listToAttrs (map wrapper ["uucico" "uuxqt" "cu" "uucp" "uuname" "uustat" "uux"]);
212 214
213 nixpkgs.config.packageOverrides = pkgs: with pkgs; { 215 nixpkgs.config.packageOverrides = pkgs: with pkgs; {
214 uucp = stdenv.lib.overrideDerivation uucp (oldAttrs: { 216 uucp = stdenv.lib.overrideDerivation uucp (oldAttrs: {