summaryrefslogtreecommitdiff
path: root/custom/tinc/def.nix
diff options
context:
space:
mode:
Diffstat (limited to 'custom/tinc/def.nix')
-rw-r--r--custom/tinc/def.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/custom/tinc/def.nix b/custom/tinc/def.nix
index 1602e477..2610a13f 100644
--- a/custom/tinc/def.nix
+++ b/custom/tinc/def.nix
@@ -127,7 +127,7 @@ in
127 Name = ${if data.name == null then "$HOST" else data.name} 127 Name = ${if data.name == null then "$HOST" else data.name}
128 DeviceType = ${data.interfaceType} 128 DeviceType = ${data.interfaceType}
129 Device = /dev/net/tun 129 Device = /dev/net/tun
130 Interface = tinc.${network} 130 Interface = ${network}
131 ExperimentalProtocol = no 131 ExperimentalProtocol = no
132 ${data.extraConfig} 132 ${data.extraConfig}
133 ''; 133 '';
@@ -136,7 +136,7 @@ in
136 )); 136 ));
137 137
138 networking.interfaces = flip mapAttrs' cfg.networks (network: data: nameValuePair 138 networking.interfaces = flip mapAttrs' cfg.networks (network: data: nameValuePair
139 ("tinc.${network}") 139 (network)
140 ({ 140 ({
141 virtual = true; 141 virtual = true;
142 virtualType = "${data.interfaceType}"; 142 virtualType = "${data.interfaceType}";