summaryrefslogtreecommitdiff
path: root/custom/tinc/def.nix
diff options
context:
space:
mode:
Diffstat (limited to 'custom/tinc/def.nix')
-rw-r--r--custom/tinc/def.nix20
1 files changed, 10 insertions, 10 deletions
diff --git a/custom/tinc/def.nix b/custom/tinc/def.nix
index 423f1ddb..58c5237c 100644
--- a/custom/tinc/def.nix
+++ b/custom/tinc/def.nix
@@ -86,13 +86,13 @@ in
86 ''; 86 '';
87 }; 87 };
88 88
89 scripts = mkOption { 89 scripts = mkOption {
90 default = { }; 90 default = { };
91 type = types.loaOf (types.nullOr types.str); 91 type = types.loaOf (types.nullOr types.str);
92 description = '' 92 description = ''
93 Hook scripts 93 Hook scripts
94 ''; 94 '';
95 }; 95 };
96 96
97 }; 97 };
98 }; 98 };
@@ -111,9 +111,9 @@ in
111 ("tinc/${network}/hosts/${host}") 111 ("tinc/${network}/hosts/${host}")
112 ({ inherit text; }) 112 ({ inherit text; })
113 ) // (flip mapAttrs' data.scripts (scriptName: text: nameValuePair 113 ) // (flip mapAttrs' data.scripts (scriptName: text: nameValuePair
114 ("tinc/${network}/${scriptName}") 114 ("tinc/${network}/${scriptName}")
115 ({ mode = "0555"; inherit text; }) 115 ({ mode = "0555"; inherit text; })
116 )) // { 116 )) // {
117 "tinc/${network}/tinc.conf" = { 117 "tinc/${network}/tinc.conf" = {
118 text = '' 118 text = ''
119 Name = ${if data.name == null then "$HOST" else data.name} 119 Name = ${if data.name == null then "$HOST" else data.name}