summaryrefslogtreecommitdiff
path: root/custom/opossum.nix
diff options
context:
space:
mode:
Diffstat (limited to 'custom/opossum.nix')
-rw-r--r--custom/opossum.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/custom/opossum.nix b/custom/opossum.nix
new file mode 100644
index 00000000..e55086c2
--- /dev/null
+++ b/custom/opossum.nix
@@ -0,0 +1,30 @@
1# This file was auto-generated by cabal2nix. Please do NOT edit manually!
2
3{ cabal, beuteltier, dataDefault, dyre, exceptions, feed, filepath
4, httpClient, httpClientTls, lenses, mtl, shellMonad, tagged, text
5, time, transformers, hxt, caseInsensitive, attoparsec
6, fetchgit
7}:
8
9cabal.mkDerivation (self: {
10 pname = "opossum";
11 version = "1.1.0";
12 src = fetchgit {
13 url = git://git.yggdrasil.li/opossum;
14 # nix-shell -p nix-prefetch-scripts --command 'nix-prefetch-git git://git.yggdrasil.li/opossum' 2>&1 | grep -E '(git revision|hash) is ' | sed -r 's/git revision is /rev = "/' | sed -r 's/hash is /sha256 = "/' | sed -r 's/$/";/'
15 rev = "47aaa1d9e622c12a6f911454e111e8228c9f592c";
16 sha256 = "18fe08a902778bf70c88954fcf659ae196da7a1ee7841344624b15bf30ad3910";
17 };
18 isLibrary = true;
19 isExecutable = true;
20 buildDepends = [
21 beuteltier dataDefault dyre exceptions feed filepath httpClient
22 httpClientTls lenses mtl shellMonad tagged text time transformers
23 hxt caseInsensitive attoparsec
24 ];
25 meta = {
26 description = "A webscraper for beuteltier";
27 license = self.stdenv.lib.licenses.publicDomain;
28 platforms = self.ghc.meta.platforms;
29 };
30})