summaryrefslogtreecommitdiff
path: root/custom/notify-user.nix
diff options
context:
space:
mode:
Diffstat (limited to 'custom/notify-user.nix')
-rw-r--r--custom/notify-user.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/custom/notify-user.nix b/custom/notify-user.nix
index f95bc43d..30a844bd 100644
--- a/custom/notify-user.nix
+++ b/custom/notify-user.nix
@@ -16,7 +16,7 @@ stdenv.mkDerivation {
16 16
17 main = do 17 main = do
18 env <- shellEnv 18 env <- shellEnv
19 either print return =<< runSh (env { envWorkDir = "/" } ) $ do 19 (either print return =<<) . runSh (env { envWorkDir = "/" } ) $ do
20 (envFile:_) <- liftIO $ glob "/home/${user}/.dbus/session-bus/*-0" 20 (envFile:_) <- liftIO $ glob "/home/${user}/.dbus/session-bus/*-0"
21 sessionAddr <- snd . break (== '=') . head . filter ("DBUS_SESSION_BUS_ADDRESS=" `isPrefixOf`) . lines <$> input envFile 21 sessionAddr <- snd . break (== '=') . head . filter ("DBUS_SESSION_BUS_ADDRESS=" `isPrefixOf`) . lines <$> input envFile
22 env <- getShellEnv 22 env <- getShellEnv