summaryrefslogtreecommitdiff
path: root/custom/luaPosix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'custom/luaPosix.nix')
-rw-r--r--custom/luaPosix.nix14
1 files changed, 14 insertions, 0 deletions
diff --git a/custom/luaPosix.nix b/custom/luaPosix.nix
new file mode 100644
index 00000000..cbaaeb2d
--- /dev/null
+++ b/custom/luaPosix.nix
@@ -0,0 +1,14 @@
1{ stdenv
2, pkgs
3, fetchurl
4}:
5
6pkgs.luaPackages.buildLuaPackage rec {
7 name = "luaposix-${version}";
8 version = "33.3.1";
9 buildInputs = (with pkgs; [ perl ]);
10 src = fetchurl {
11 url = "https://github.com/luaposix/luaposix/archive/release-v${version}.tar.gz";
12 sha256 = "1kxkn4hisx8454s4rid5p4xxq866x16f1hbzjzrd00qc9nkfvqa9";
13 };
14}