summaryrefslogtreecommitdiff
path: root/custom/beuteltier.nix
diff options
context:
space:
mode:
Diffstat (limited to 'custom/beuteltier.nix')
l---------[-rw-r--r--]custom/beuteltier.nix31
1 files changed, 1 insertions, 30 deletions
diff --git a/custom/beuteltier.nix b/custom/beuteltier.nix
index 6b47b31d..8320fd02 100644..120000
--- a/custom/beuteltier.nix
+++ b/custom/beuteltier.nix
@@ -1,30 +1 @@
1# This file was auto-generated by cabal2nix. Please do NOT edit manually! ../beuteltier/beuteltier.nix \ No newline at end of file
2
3{ cabal, aeson, dataDefault, filepath, lenses, mtl, tar, text
4, transformers, yaml, zlib, cryptohash, time, base16Bytestring
5, attoparsecExpr, caseInsensitive, timeparsers
6, fetchgit
7}:
8
9cabal.mkDerivation (self: {
10 pname = "beuteltier";
11 version = "6.0.1";
12 #src = ./.;
13 src = fetchgit {
14 url = git://git.yggdrasil.li/beuteltier;
15 # nix-shell -p nix-prefetch-scripts --command 'nix-prefetch-git git://git.yggdrasil.li/beuteltier' 2>&1 | grep -E '(git revision|hash) is ' | sed -r 's/git revision is /rev = "/' | sed -r 's/hash is /sha256 = "/' | sed -r 's/$/";/'
16 rev = "f4c0bc02bbb8ed61b383b4c7dd7fc7a1d4e7c85e";
17 sha256 = "795a137c7972ef5da3c662bfbd59550573cb283fae83527efa9a99a66d7b4c98";
18 };
19 buildDepends = [
20 aeson dataDefault filepath lenses mtl tar text transformers yaml
21 zlib cryptohash time base16Bytestring attoparsecExpr caseInsensitive
22 timeparsers
23 ];
24 meta = {
25 homepage = "git://git.yggdrasil.li/beuteltier";
26 description = "Accessor library for \"Beutel\" (Bag) - a backstore (directory) containing tracked objects (.tgz files with a yaml manifest inside)";
27 license = self.stdenv.lib.licenses.publicDomain;
28 platforms = self.ghc.meta.platforms;
29 };
30})