summaryrefslogtreecommitdiff
path: root/bragi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'bragi.nix')
-rw-r--r--bragi.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/bragi.nix b/bragi.nix
index a9df4061..95d39e9a 100644
--- a/bragi.nix
+++ b/bragi.nix
@@ -85,8 +85,10 @@ in rec {
85 nixpkgs.config = { 85 nixpkgs.config = {
86 packageOverrides = pkgs: with pkgs; { 86 packageOverrides = pkgs: with pkgs; {
87 haskellPackages = haskellPackages.override { 87 haskellPackages = haskellPackages.override {
88 overrides = self: super: { 88 overrides = self: super: with super; {
89 encoding = haskell.lib.overrideCabal super.encoding ( oldAttrs: { src = fetchFromGitHub { owner = "pngwjpgh"; repo = "encoding"; rev = "extended-version-bounds"; sha256 = "0pzxixp384a1ywzj56pl7xc4ln7i9x6mq8spqjwcs80y0pgfpp9s"; }; } ); 89 encoding = haskell.lib.overrideCabal encoding ( oldAttrs: {
90 src = fetchFromGitHub { owner = "pngwjpgh"; repo = "encoding"; rev = "extended-version-bounds"; sha256 = "0pzxixp384a1ywzj56pl7xc4ln7i9x6mq8spqjwcs80y0pgfpp9s"; };
91 });
90 trivmix = self.callPackage ./custom/trivmix/trivmix.nix {}; 92 trivmix = self.callPackage ./custom/trivmix/trivmix.nix {};
91 inherit 93 inherit
92 (lib.mapAttrs (name: haskell.lib.dontCheck) super) 94 (lib.mapAttrs (name: haskell.lib.dontCheck) super)