summaryrefslogtreecommitdiff
path: root/bragi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'bragi.nix')
-rw-r--r--bragi.nix37
1 files changed, 25 insertions, 12 deletions
diff --git a/bragi.nix b/bragi.nix
index 68a4e017..fadf6349 100644
--- a/bragi.nix
+++ b/bragi.nix
@@ -74,18 +74,31 @@ in rec {
74 ''; 74 '';
75 }; 75 };
76 76
77 services.autofs = { 77 systemd.automounts = [
78 enable = true; 78 { where = "/media/odin"; }
79 autoMaster = let 79 { where = "/media/dellingr"; }
80 mapConf = pkgs.writeText "auto" '' 80 { where = "/media/vali"; }
81 odin -fstype=nfs,ro odin.asgard.yggdrasil:/srv/media 81 ];
82 dellingr -fstype=vfat,ro /dev/disk/by-uuid/6436-3432 82
83 vali -fstype=cifs,guest //VALI/Public 83 systemd.mounts = [
84 ''; 84 {
85 in '' 85 what = "odin.asgard.yggdrasil:/srv/media";
86 /media file:${mapConf} 86 where = "/media/odin";
87 ''; 87 type = "nfs";
88 }; 88 options = "ro";
89 }
90 {
91 what = "/dev/disk/by-uuid/6436-3432";
92 where = "/media/dellingr";
93 type = "vfat";
94 }
95 {
96 what = "//VALI/Public";
97 where = "/media/vali";
98 type = "cifs";
99 options = "guest";
100 }
101 ];
89 102
90 systemd.globalEnvironment = { 103 systemd.globalEnvironment = {
91 JACK_PROMISCUOUS_SERVER = "1"; 104 JACK_PROMISCUOUS_SERVER = "1";