summaryrefslogtreecommitdiff
path: root/bragi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'bragi.nix')
-rw-r--r--bragi.nix14
1 files changed, 12 insertions, 2 deletions
diff --git a/bragi.nix b/bragi.nix
index d77bc991..ba127f1c 100644
--- a/bragi.nix
+++ b/bragi.nix
@@ -1,6 +1,8 @@
1{ config, pkgs, ... }: 1{ config, pkgs, ... }:
2 2
3{ 3let
4 jack2 = pkgs.callPackage ./jack2.nix {};
5in {
4 imports = 6 imports =
5 [ 7 [
6 ./bragi-hw.nix 8 ./bragi-hw.nix
@@ -31,7 +33,7 @@
31 rsync 33 rsync
32 tmux 34 tmux
33 nfs-utils 35 nfs-utils
34 (callPackage ./jack2.nix {}) 36 jack2
35 ]; 37 ];
36 38
37 # List services that you want to enable: 39 # List services that you want to enable:
@@ -78,4 +80,12 @@
78 { domain = "@audio"; item = "nofile"; type = "soft"; value = "99999"; } 80 { domain = "@audio"; item = "nofile"; type = "soft"; value = "99999"; }
79 { domain = "@audio"; item = "nofile"; type = "hard"; value = "99999"; } 81 { domain = "@audio"; item = "nofile"; type = "hard"; value = "99999"; }
80 ]; 82 ];
83
84 systemd.services.jack = {
85 wantedBy = [ "sound.target" ];
86 serviceConfig = {
87 Type = "simple";
88 ExecStart = "${jack2}/bin/jackd -d alsa -M -H -r 96000";
89 };
90 };
81} 91}