summaryrefslogtreecommitdiff
path: root/bragi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'bragi.nix')
-rw-r--r--bragi.nix41
1 files changed, 0 insertions, 41 deletions
diff --git a/bragi.nix b/bragi.nix
index f76aef61..70d16cbb 100644
--- a/bragi.nix
+++ b/bragi.nix
@@ -64,47 +64,6 @@ in rec {
64 }; 64 };
65 }; 65 };
66 66
67 services.radvd = {
68 enable = true;
69 config = ''
70 interface eth {
71 AdvSendAdvert on;
72 MinRtrAdvInterval 3;
73 MaxRtrAdvInterval 10;
74
75 prefix ffff:ffff:ffff:ffff::/64 {
76 Base6Interface eth;
77
78 AdvOnLink on;
79 AdvAutonomous on;
80 # AdvRouterAddr on;
81 };
82 };
83
84 interface wlp4s0 {
85 AdvSendAdvert on;
86 MinRtrAdvInterval 3;
87 MaxRtrAdvInterval 10;
88
89 prefix ffff:ffff:ffff:ffff::/64 {
90 Base6Interface eth;
91
92 AdvOnLink on;
93 AdvAutonomous on;
94 # AdvRouterAddr on;
95 };
96 };
97 '';
98 };
99
100 systemd.services.radvd = {
101 path = with pkgs; [procps];
102 preStart = ''
103 sysctl net.ipv6.conf.eth.forwarding=1
104 sysctl net.ipv6.conf.wlp4s0.forwarding=1
105 '';
106 };
107
108 services.dhcpd4 = { 67 services.dhcpd4 = {
109 enable = true; 68 enable = true;
110 interfaces = [ "eth" 69 interfaces = [ "eth"