summaryrefslogtreecommitdiff
path: root/bragi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'bragi.nix')
-rw-r--r--bragi.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/bragi.nix b/bragi.nix
index 59bcbd1e..ba1a121b 100644
--- a/bragi.nix
+++ b/bragi.nix
@@ -85,12 +85,12 @@ in rec {
85 nixpkgs.config = { 85 nixpkgs.config = {
86 packageOverrides = oldPkgs: with oldPkgs; { 86 packageOverrides = oldPkgs: with oldPkgs; {
87 haskellPackages = haskellPackages.override { 87 haskellPackages = haskellPackages.override {
88 overrides = self: super: with super; { 88 overrides = self: super: with self; {
89 encoding = haskell.lib.overrideCabal encoding ( oldAttrs: { 89 encoding = haskell.lib.overrideCabal encoding ( oldAttrs: {
90 src = fetchFromGitHub { owner = "pngwjpgh"; repo = "encoding"; rev = "extended-version-bounds"; sha256 = "0pzxixp384a1ywzj56pl7xc4ln7i9x6mq8spqjwcs80y0pgfpp9s"; }; 90 src = fetchFromGitHub { owner = "pngwjpgh"; repo = "encoding"; rev = "extended-version-bounds"; sha256 = "0pzxixp384a1ywzj56pl7xc4ln7i9x6mq8spqjwcs80y0pgfpp9s"; };
91 }); 91 });
92 inherit 92 inherit
93 (lib.mapAttrs (name: haskell.lib.dontCheck) super) 93 (lib.mapAttrs (name: haskell.lib.dontCheck) self)
94 Glob filelock hedgehog; 94 Glob filelock hedgehog;
95 inherit 95 inherit
96 (self.callPackage ./custom/thermoprint { inherit runCommand makeWrapper; extraPackages = (p: with p; [ persistent-postgresql ]); }) 96 (self.callPackage ./custom/thermoprint { inherit runCommand makeWrapper; extraPackages = (p: with p; [ persistent-postgresql ]); })