summaryrefslogtreecommitdiff
path: root/bragi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'bragi.nix')
-rw-r--r--bragi.nix11
1 files changed, 8 insertions, 3 deletions
diff --git a/bragi.nix b/bragi.nix
index 8c3ecbb2..f70df421 100644
--- a/bragi.nix
+++ b/bragi.nix
@@ -32,10 +32,15 @@ in rec {
32 pkgs.haskellPackages.override { 32 pkgs.haskellPackages.override {
33 overrides = self: super: let 33 overrides = self: super: let
34 callPackage = pkgs.lib.callPackageWith ( pkgs // self ); 34 callPackage = pkgs.lib.callPackageWith ( pkgs // self );
35 in lib.mapAttrs (name: pkg: pkgs.haskell.lib.dontCheck pkg) (super // { 35 in {
36 trivmix = callPackage ./custom/trivmix {}; 36 trivmix = callPackage ./custom/trivmix {};
37 inherit (pkgs.callPackage ./custom/thermoprint { extraPackages = (p: with p; [ persistent-postgresql ]); }) thermoprint-spec thermoprint-bbcode thermoprint-client thermoprint-server thermoprint-webgui tprint bbcode; 37 inherit
38 }); 38 (lib.mapAttrs (name: pkgs.haskell.lib.dontCheck) super)
39 Glob;
40 inherit
41 (pkgs.callPackage ./custom/thermoprint { extraPackages = (p: with p; [ persistent-postgresql ]); })
42 thermoprint-spec thermoprint-bbcode thermoprint-client thermoprint-server thermoprint-webgui tprint bbcode;
43 };
39 } 44 }
40 ); 45 );
41 46