summaryrefslogtreecommitdiff
path: root/bragi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'bragi.nix')
-rw-r--r--bragi.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/bragi.nix b/bragi.nix
index a7059836..a9df4061 100644
--- a/bragi.nix
+++ b/bragi.nix
@@ -82,7 +82,8 @@ in rec {
82 wantedBy = [ "network.target" ]; 82 wantedBy = [ "network.target" ];
83 }; 83 };
84 84
85 nixpkgs.config.packageOverrides = pkgs: with pkgs; { 85 nixpkgs.config = {
86 packageOverrides = pkgs: with pkgs; {
86 haskellPackages = haskellPackages.override { 87 haskellPackages = haskellPackages.override {
87 overrides = self: super: { 88 overrides = self: super: {
88 encoding = haskell.lib.overrideCabal super.encoding ( oldAttrs: { src = fetchFromGitHub { owner = "pngwjpgh"; repo = "encoding"; rev = "extended-version-bounds"; sha256 = "0pzxixp384a1ywzj56pl7xc4ln7i9x6mq8spqjwcs80y0pgfpp9s"; }; } ); 89 encoding = haskell.lib.overrideCabal super.encoding ( oldAttrs: { src = fetchFromGitHub { owner = "pngwjpgh"; repo = "encoding"; rev = "extended-version-bounds"; sha256 = "0pzxixp384a1ywzj56pl7xc4ln7i9x6mq8spqjwcs80y0pgfpp9s"; }; } );
@@ -103,7 +104,8 @@ in rec {
103 inherit (haskellPackages) trivmix thermoprint-server thermoprint-webgui tprint; 104 inherit (haskellPackages) trivmix thermoprint-server thermoprint-webgui tprint;
104 }; 105 };
105 106
106 nixpkgs.config.allowUnfree = true; 107 allowUnfree = true;
108 };
107 109
108 environment.systemPackages = with pkgs; [ 110 environment.systemPackages = with pkgs; [
109 git 111 git