diff options
Diffstat (limited to 'bragi.nix')
-rw-r--r-- | bragi.nix | 7 |
1 files changed, 3 insertions, 4 deletions
@@ -28,18 +28,17 @@ in rec { | |||
28 | 28 | ||
29 | nixpkgs.config.packageOverrides = oldPkgs: | 29 | nixpkgs.config.packageOverrides = oldPkgs: |
30 | rec { | 30 | rec { |
31 | haskellPackages = oldPkgs.haskell.packages.ghc802.override { | 31 | haskellPackages = oldPkgs.haskellPackages { |
32 | overrides = self: super: { | 32 | overrides = self: super: { |
33 | trivmix = self.callPackage ./custom/trivmix/trivmix.nix {}; | 33 | trivmix = self.callPackage ./custom/trivmix/trivmix.nix {}; |
34 | inherit | 34 | inherit |
35 | (lib.mapAttrs (name: pkgs.haskell.lib.dontCheck) super) | 35 | (lib.mapAttrs (name: oldPkgs.haskell.lib.dontCheck) super) |
36 | Glob filelock; | 36 | Glob filelock; |
37 | inherit | 37 | inherit |
38 | ((import ./custom/thermoprint) { extraPackages = (p: with p; [ persistent-postgresql ]); }) | 38 | (pkgs.lib.callPackageWith (pkgs // self) ./custom/thermoprint { extraPackages = (p: with p; [ persistent-postgresql ]); }) |
39 | thermoprint-spec thermoprint-bbcode thermoprint-client thermoprint-server thermoprint-webgui tprint bbcode; | 39 | thermoprint-spec thermoprint-bbcode thermoprint-client thermoprint-server thermoprint-webgui tprint bbcode; |
40 | }; | 40 | }; |
41 | }; | 41 | }; |
42 | haskell.packages.ghc802 = haskellPackages; | ||
43 | 42 | ||
44 | jack2Full = oldPkgs.jack2Full.override { dbus = null; }; | 43 | jack2Full = oldPkgs.jack2Full.override { dbus = null; }; |
45 | 44 | ||