diff options
Diffstat (limited to 'bragi.nix')
-rw-r--r-- | bragi.nix | 33 |
1 files changed, 17 insertions, 16 deletions
@@ -1,8 +1,6 @@ | |||
1 | { config, pkgs, ... }: | 1 | { config, pkgs, ... }: |
2 | 2 | ||
3 | let | 3 | let |
4 | trivmixService = opts: (pkgs.callPackage ./custom/trivmix-service.nix opts).out; | ||
5 | thermoprint-servant = (pkgs.callPackage ./custom/thermoprint {}).thermoprint-servant; | ||
6 | inherit (pkgs) lib; | 4 | inherit (pkgs) lib; |
7 | in rec { | 5 | in rec { |
8 | imports = | 6 | imports = |
@@ -11,6 +9,7 @@ in rec { | |||
11 | ./custom/zsh.nix | 9 | ./custom/zsh.nix |
12 | ./users.nix | 10 | ./users.nix |
13 | ./custom/unit-status-mail.nix | 11 | ./custom/unit-status-mail.nix |
12 | ./custom/trivmix-service.nix | ||
14 | ]; | 13 | ]; |
15 | 14 | ||
16 | boot.loader.grub.enable = true; | 15 | boot.loader.grub.enable = true; |
@@ -145,26 +144,28 @@ in rec { | |||
145 | }; | 144 | }; |
146 | }; | 145 | }; |
147 | 146 | ||
148 | systemd.services."mpdmix0" = trivmixService { name = "mpdmix0"; connectOut = "outnode0:in"; group = "mpd"; initial = "-35dB"; }; | 147 | services.trivmix = { |
149 | systemd.services."mpdmix1" = trivmixService { name = "mpdmix1"; connectOut = "outnode1:in"; group = "mpd"; initial = "-35dB"; }; | 148 | mpdmix0 = { connectOut = "outnode0:in"; group = "mpd"; initial = "-35dB"; }; |
149 | mpdmix1 = { connectOut = "outnode1:in"; group = "mpd"; initial = "-35dB"; }; | ||
150 | 150 | ||
151 | systemd.services."passmix0" = trivmixService { name = "passmix0"; connectOut = "outnode0:in"; connectIn = "system:capture_5"; group = "vali_out"; initial = "-5dB"; }; | 151 | passmix0 = { connectOut = "outnode0:in"; connectIn = "system:capture_5"; group = "vali_out"; initial = "-5dB"; }; |
152 | systemd.services."passmix1" = trivmixService { name = "passmix1"; connectOut = "outnode1:in"; connectIn = "system:capture_6"; group = "vali_out"; initial = "-5dB"; }; | 152 | passmix1 = { connectOut = "outnode1:in"; connectIn = "system:capture_6"; group = "vali_out"; initial = "-5dB"; }; |
153 | 153 | ||
154 | systemd.services."passmix2" = trivmixService { name = "passmix2"; connectOut = "system:playback_5"; connectIn = "system:capture_1"; group = "mic_out"; initial = "1"; }; | 154 | passmix2 = { connectOut = "system:playback_5"; connectIn = "system:capture_1"; group = "mic_out"; initial = "1"; }; |
155 | systemd.services."passmix3" = trivmixService { name = "passmix3"; connectOut = "system:playback_6"; connectIn = "system:capture_1"; group = "mic_out"; initial = "1"; }; | 155 | passmix3 = { connectOut = "system:playback_6"; connectIn = "system:capture_1"; group = "mic_out"; initial = "1"; }; |
156 | 156 | ||
157 | systemd.services."passmix4" = trivmixService { name = "passmix4"; connectOut = "outnode0:in"; connectIn = "system:capture_7"; group = "hel_out"; initial = "-5dB"; }; | 157 | passmix4 = { connectOut = "outnode0:in"; connectIn = "system:capture_7"; group = "hel_out"; initial = "-5dB"; }; |
158 | systemd.services."passmix5" = trivmixService { name = "passmix5"; connectOut = "outnode1:in"; connectIn = "system:capture_8"; group = "hel_out"; initial = "-5dB"; }; | 158 | passmix5 = { connectOut = "outnode1:in"; connectIn = "system:capture_8"; group = "hel_out"; initial = "-5dB"; }; |
159 | 159 | ||
160 | systemd.services."outnode0" = trivmixService { name = "outnode0"; initial = "1"; }; | 160 | outnode0 = { initial = "1"; }; |
161 | systemd.services."outnode1" = trivmixService { name = "outnode1"; initial = "1"; }; | 161 | outnode1 = { initial = "1"; }; |
162 | 162 | ||
163 | systemd.services."headphones0" = trivmixService { name = "heaphones0"; connectOut = "system:playback_3"; connectIn = "outnode0:out"; group = "headphones"; initial = "1"; }; | 163 | headphones0 = { connectOut = "system:playback_3"; connectIn = "outnode0:out"; group = "headphones"; initial = "1"; }; |
164 | systemd.services."headphones1" = trivmixService { name = "heaphones1"; connectOut = "system:playback_4"; connectIn = "outnode1:out"; group = "headphones"; initial = "1"; }; | 164 | headphones1 = { connectOut = "system:playback_4"; connectIn = "outnode1:out"; group = "headphones"; initial = "1"; }; |
165 | 165 | ||
166 | systemd.services."speakers0" = trivmixService { name = "speakers0"; connectOut = "system:playback_7"; connectIn = "outnode0:out"; group = "speakers"; initial = "0"; }; | 166 | speakers0 = { connectOut = "system:playback_7"; connectIn = "outnode0:out"; group = "speakers"; initial = "0"; }; |
167 | systemd.services."speakers1" = trivmixService { name = "speakers1"; connectOut = "system:playback_8"; connectIn = "outnode1:out"; group = "speakers"; initial = "0"; }; | 167 | speakers1 = { connectOut = "system:playback_8"; connectIn = "outnode1:out"; group = "speakers"; initial = "0"; }; |
168 | }; | ||
168 | 169 | ||
169 | services.mpd = { | 170 | services.mpd = { |
170 | enable = true; | 171 | enable = true; |