summaryrefslogtreecommitdiff
path: root/bragi-hw.nix
diff options
context:
space:
mode:
Diffstat (limited to 'bragi-hw.nix')
-rw-r--r--bragi-hw.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/bragi-hw.nix b/bragi-hw.nix
new file mode 100644
index 00000000..6a14ff09
--- /dev/null
+++ b/bragi-hw.nix
@@ -0,0 +1,27 @@
1{ config, lib, pkgs, ... }:
2
3{
4 imports =
5 [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
6 ];
7
8 boot.initrd.availableKernelModules = [ "ahci" "ohci_pci" "ehci_pci" "usb_storage" ];
9 boot.kernelModules = [ "kvm-amd" ];
10 boot.extraModulePackages = [ ];
11
12 fileSystems."/" =
13 { device = "/dev/disk/by-uuid/15fc072d-5fdf-4ec7-b029-50d09b4dc5ea";
14 fsType = "ext4";
15 };
16
17 fileSystems."/home" =
18 { device = "/dev/disk/by-uuid/c76d9b7c-ba84-49d3-a7c9-b53e201b76c6";
19 fsType = "ext4";
20 };
21
22 swapDevices =
23 [ { device = "/dev/disk/by-uuid/2b13b997-59e8-4f59-bc84-554eb0df7482"; }
24 ];
25
26 nix.maxJobs = 2;
27}