summaryrefslogtreecommitdiff
path: root/accounts/gkleen@sif/systemd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/gkleen@sif/systemd.nix')
-rw-r--r--accounts/gkleen@sif/systemd.nix20
1 files changed, 18 insertions, 2 deletions
diff --git a/accounts/gkleen@sif/systemd.nix b/accounts/gkleen@sif/systemd.nix
index 886f6da1..eb10cd78 100644
--- a/accounts/gkleen@sif/systemd.nix
+++ b/accounts/gkleen@sif/systemd.nix
@@ -189,6 +189,22 @@ in {
189 StartLimitBurst = 7; 189 StartLimitBurst = 7;
190 }; 190 };
191 }; 191 };
192 "autossh-socks@proxy.mathw0e:8125" = {
193 Service = {
194 Type = "notify";
195 NotifyAccess = "all";
196 WorkingDirectory = "~";
197 Restart = "always";
198 RestartSec = "23s";
199 ExecStart = "${autossh-socks-script} \"%I\"";
200 Environment = [ "SSHPASS_SECRET=gkleen@mathw0e.mathinst.loc" ];
201 };
202 Unit = {
203 StopWhenUnneeded = true;
204 StartLimitInterval = "180s";
205 StartLimitBurst = 7;
206 };
207 };
192 swayidle = { 208 swayidle = {
193 Service = { 209 Service = {
194 RuntimeDirectory = "swayidle"; 210 RuntimeDirectory = "swayidle";
@@ -370,7 +386,7 @@ in {
370 Service = { 386 Service = {
371 ExecStart = "${config.systemd.package}/lib/systemd/systemd-socket-proxyd --exit-idle-time=10s 127.0.0.1:${toString (port + 1)}"; 387 ExecStart = "${config.systemd.package}/lib/systemd/systemd-socket-proxyd --exit-idle-time=10s 127.0.0.1:${toString (port + 1)}";
372 }; 388 };
373 }) [{ host = "proxy.ssh.math.lmu.de"; port = 8118; } { host = "proxy.vidhar"; port = 8120; } { host = "proxy.mathw0h"; port = 8122; }]); 389 }) [{ host = "proxy.ssh.math.lmu.de"; port = 8118; } { host = "proxy.vidhar"; port = 8120; } { host = "proxy.mathw0h"; port = 8122; } { host = "proxy.mathw0e"; port = 8124; }]);
374 sockets = listToAttrs (map (port: nameValuePair "proxy-to-autossh-socks@${toString port}" { 390 sockets = listToAttrs (map (port: nameValuePair "proxy-to-autossh-socks@${toString port}" {
375 Socket = { 391 Socket = {
376 ListenStream = "%I"; 392 ListenStream = "%I";
@@ -378,7 +394,7 @@ in {
378 Install = { 394 Install = {
379 WantedBy = ["default.target"]; 395 WantedBy = ["default.target"];
380 }; 396 };
381 }) [8118 8120 8122]) // { 397 }) [8118 8120 8122 8124]) // {
382 "yt-dlp" = { 398 "yt-dlp" = {
383 Socket = { 399 Socket = {
384 SocketMode = "0600"; 400 SocketMode = "0600";