summaryrefslogtreecommitdiff
path: root/accounts/gkleen@sif/systemd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/gkleen@sif/systemd.nix')
-rw-r--r--accounts/gkleen@sif/systemd.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/accounts/gkleen@sif/systemd.nix b/accounts/gkleen@sif/systemd.nix
index 20db64a0..d654811e 100644
--- a/accounts/gkleen@sif/systemd.nix
+++ b/accounts/gkleen@sif/systemd.nix
@@ -287,8 +287,9 @@ in {
287 WatchdogSec = "30min"; 287 WatchdogSec = "30min";
288 Environment = [ 288 Environment = [
289 "PATH=${lib.makeBinPath (with pkgs; [atomicparsley ffmpeg-headless rtmpdump])}" 289 "PATH=${lib.makeBinPath (with pkgs; [atomicparsley ffmpeg-headless rtmpdump])}"
290 "DSCP=8"
290 ]; 291 ];
291 ExecStart = pkgs.writers.writePython3 "yt-dlp" { 292 ExecStart = ''${lib.getExe pkgs.dscp} ${pkgs.writers.writePython3 "yt-dlp" {
292 libraries = with pkgs.python3Packages; [ yt-dlp sdnotify ]; 293 libraries = with pkgs.python3Packages; [ yt-dlp sdnotify ];
293 } '' 294 } ''
294 import json 295 import json
@@ -316,7 +317,7 @@ in {
316 with YoutubeDL(ydl_opts) as ytdl: 317 with YoutubeDL(ydl_opts) as ytdl:
317 n.notify('READY=1') 318 n.notify('READY=1')
318 ytdl.download(args['urls']) 319 ytdl.download(args['urls'])
319 ''; 320 ''}'';
320 ExecStopPost = "${pkgs.coreutils}/bin/rm -rfv \"$CACHE_DIRECTORY\""; 321 ExecStopPost = "${pkgs.coreutils}/bin/rm -rfv \"$CACHE_DIRECTORY\"";
321 }; 322 };
322 }; 323 };