summaryrefslogtreecommitdiff
path: root/accounts/gkleen@sif/systemd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/gkleen@sif/systemd.nix')
-rw-r--r--accounts/gkleen@sif/systemd.nix30
1 files changed, 23 insertions, 7 deletions
diff --git a/accounts/gkleen@sif/systemd.nix b/accounts/gkleen@sif/systemd.nix
index 34f52172..bce2f4cd 100644
--- a/accounts/gkleen@sif/systemd.nix
+++ b/accounts/gkleen@sif/systemd.nix
@@ -123,7 +123,8 @@ in {
123 }; 123 };
124 emacs = { 124 emacs = {
125 Unit = { 125 Unit = {
126 After = ["graphical-session-pre.target"]; 126 After = [ "graphical-session.target" ];
127 BindsTo = [ "graphical-session.target" ];
127 }; 128 };
128 }; 129 };
129 keepassxc = { 130 keepassxc = {
@@ -135,8 +136,8 @@ in {
135 Environment = [ "QT_QPA_PLATFORM=wayland" ]; 136 Environment = [ "QT_QPA_PLATFORM=wayland" ];
136 }; 137 };
137 Unit = { 138 Unit = {
138 Requires = ["graphical-session-pre.target"]; 139 After = [ "graphical-session.target" ];
139 After = ["graphical-session-pre.target"]; 140 BindsTo = [ "graphical-session.target" ];
140 }; 141 };
141 }; 142 };
142 mpris-proxy = { 143 mpris-proxy = {
@@ -184,8 +185,8 @@ in {
184 WantedBy = ["graphical-session.target"]; 185 WantedBy = ["graphical-session.target"];
185 }; 186 };
186 Unit = { 187 Unit = {
187 Requires = ["graphical-session-pre.target"]; 188 After = [ "graphical-session.target" ];
188 After = ["graphical-session-pre.target"]; 189 PartOf = [ "graphical-session.target" ];
189 }; 190 };
190 Service = { 191 Service = {
191 ExecStart = lib.getExe pkgs.psi-notify; 192 ExecStart = lib.getExe pkgs.psi-notify;
@@ -198,6 +199,7 @@ in {
198 gtklock = { 199 gtklock = {
199 Unit = { 200 Unit = {
200 Requisite = ["graphical-session.target"]; 201 Requisite = ["graphical-session.target"];
202 After = [ "graphical-session.target" ];
201 PartOf = ["graphical-session.target"]; 203 PartOf = ["graphical-session.target"];
202 }; 204 };
203 Service = { 205 Service = {
@@ -304,8 +306,8 @@ in {
304 WantedBy = ["graphical-session.target"]; 306 WantedBy = ["graphical-session.target"];
305 }; 307 };
306 Unit = { 308 Unit = {
307 BindsTo = ["graphical-session-pre.target"]; 309 After = [ "graphical-session.target" ];
308 After = ["graphical-session-pre.target"]; 310 PartOf = [ "graphical-session.target" ];
309 }; 311 };
310 Service = { 312 Service = {
311 ExecStart = lib.getExe cfg.programs.wpaperd.package; 313 ExecStart = lib.getExe cfg.programs.wpaperd.package;
@@ -314,6 +316,17 @@ in {
314 RestartSec = "2s"; 316 RestartSec = "2s";
315 }; 317 };
316 }; 318 };
319 xembed-sni-proxy = {
320 Unit = {
321 BindsTo = ["xwayland-satellite.service"];
322 After = ["xwayland-satellite.service"];
323 };
324 };
325 poweralertd = {
326 Unit = {
327 After = ["graphical-session.target"];
328 };
329 };
317 } // listToAttrs (map ({host, port}: nameValuePair "proxy-to-autossh-socks@${toString port}" { 330 } // listToAttrs (map ({host, port}: nameValuePair "proxy-to-autossh-socks@${toString port}" {
318 Unit = { 331 Unit = {
319 Requires = ["autossh-socks@${host}:${toString (port + 1)}.service" "proxy-to-autossh-socks@${toString port}.socket"]; 332 Requires = ["autossh-socks@${host}:${toString (port + 1)}.service" "proxy-to-autossh-socks@${toString port}.socket"];
@@ -364,6 +377,9 @@ in {
364 }; 377 };
365 tray = { 378 tray = {
366 Unit = { 379 Unit = {
380 PartOf = [ "graphical-session.target" ];
381 Requires = [ "waybar.service" ];
382 After = [ "graphical-session.target" "waybar.service" ];
367 Wants = ["blueman-applet.service" "udiskie.service" "network-manager-applet.service"]; 383 Wants = ["blueman-applet.service" "udiskie.service" "network-manager-applet.service"];
368 }; 384 };
369 }; 385 };