summaryrefslogtreecommitdiff
path: root/accounts/gkleen@sif/libvirt/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/gkleen@sif/libvirt/default.nix')
-rw-r--r--accounts/gkleen@sif/libvirt/default.nix34
1 files changed, 30 insertions, 4 deletions
diff --git a/accounts/gkleen@sif/libvirt/default.nix b/accounts/gkleen@sif/libvirt/default.nix
index 54d971c4..076a0d86 100644
--- a/accounts/gkleen@sif/libvirt/default.nix
+++ b/accounts/gkleen@sif/libvirt/default.nix
@@ -15,11 +15,13 @@ with flakeInputs.nixVirt.lib;
15 memory = { count = 16; unit = "GiB"; }; 15 memory = { count = 16; unit = "GiB"; };
16 storage_vol = "/home/gkleen/.local/share/libvirt/images/lmmirzm-vmrz01.qcow2"; 16 storage_vol = "/home/gkleen/.local/share/libvirt/images/lmmirzm-vmrz01.qcow2";
17 nvram_path = "/home/gkleen/.local/share/libvirt/lmmirzm-vmrz01.nvram"; 17 nvram_path = "/home/gkleen/.local/share/libvirt/lmmirzm-vmrz01.nvram";
18 virtio_net = true;
19 virtio_drive = true; 18 virtio_drive = true;
20 virtio_video = false; 19 virtio_video = false;
21 install_virtio = true; 20 install_virtio = false;
22 }) { 21 }) {
22 qemu-commandline.env = [
23 { name = "SPICE_DEBUG_ALLOW_MC"; value = "1"; }
24 ];
23 vcpu.count = 4; 25 vcpu.count = 4;
24 os.bootmenu.enable = true; 26 os.bootmenu.enable = true;
25 devices.graphics = { 27 devices.graphics = {
@@ -27,18 +29,42 @@ with flakeInputs.nixVirt.lib;
27 # gl.enable = true; 29 # gl.enable = true;
28 }; 30 };
29 devices.interface = { 31 devices.interface = {
32 model.type = "virtio";
30 type = "bridge"; 33 type = "bridge";
31 mac.address = "52:54:00:b9:f3:ed"; 34 mac.address = "52:54:00:b9:f3:ed";
32 source.bridge = "gre-0971"; 35 source.bridge = "gre-0971";
33 }; 36 };
37 devices.channel = [
38 {
39 type = "unix";
40 target = { type = "virtio"; name = "org.qemu.guest_agent.0"; };
41 }
42 ];
43 devices.tpm.model = "tpm-tis";
34 }); 44 });
35 } 45 }
36 ]; 46 ];
37 pools = [ 47 pools = [
38 { definition = ./pool-default.xml; 48 { definition = pool.writeXML {
49 type = "dir";
50 name = "default";
51 uuid = "ad899c92-02e3-45f9-bf49-195467aba2e2";
52 target = {
53 path = "/home/gkleen/.local/share/libvirt/images";
54 };
55 };
39 active = true; 56 active = true;
40 volumes = [ 57 volumes = [
41 { definition = ./vol-lmmirzm-vmrz01.xml; 58 { definition = volume.writeXML {
59 type = "file";
60 name = "lmmirzm-vmrz01.qcow2";
61 capacity = { count = 40; unit = "GB"; };
62 target = {
63 path = "/home/gkleen/.local/share/libvirt/images/lmmirzm-vmrz01.qcow2";
64 format.type = "qcow2";
65 features.lazy_refcounts = {};
66 };
67 };
42 } 68 }
43 ]; 69 ];
44 } 70 }