summaryrefslogtreecommitdiff
path: root/accounts/gkleen@sif/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/gkleen@sif/default.nix')
-rw-r--r--accounts/gkleen@sif/default.nix27
1 files changed, 17 insertions, 10 deletions
diff --git a/accounts/gkleen@sif/default.nix b/accounts/gkleen@sif/default.nix
index 84b9e464..f28cf4e2 100644
--- a/accounts/gkleen@sif/default.nix
+++ b/accounts/gkleen@sif/default.nix
@@ -88,12 +88,13 @@ in {
88 emacs = { 88 emacs = {
89 enable = true; 89 enable = true;
90 extraPackages = epkgs: with epkgs; [ 90 extraPackages = epkgs: with epkgs; [
91 evil evil-dvorak undo-tree magit haskell-mode 91 evil evil-dvorak undo-tree magit haskell-mode nix-mode
92 nix-mode yaml-mode json-mode shakespeare-mode 92 yaml-mode json-mode shakespeare-mode smart-mode-line
93 smart-mode-line highlight-parentheses highlight-symbol 93 highlight-parentheses highlight-symbol ag sass-mode lua-mode
94 ag sass-mode lua-mode fira-code-mode use-package # notmuch 94 fira-code-mode use-package # notmuch
95 use-package-ensure-system-package git-gutter emacsScratch 95 use-package-ensure-system-package git-gutter emacsScratch
96 edit-server mediawiki editorconfig typescript-mode 96 edit-server mediawiki editorconfig typescript-mode
97 markdown-mode
97 ]; 98 ];
98 }; 99 };
99 firefox = { 100 firefox = {
@@ -123,14 +124,20 @@ in {
123 124
124 autorandr = { 125 autorandr = {
125 enable = true; 126 enable = true;
126 hooks.postswitch = { 127 hooks = {
127 # "restart-compton" = "${pkgs.systemd}/bin/systemctl --user try-restart picom"; 128 preswitch = {
128 "restart-trays" = '' 129 "stop-tray" = ''
129 ${pkgs.coreutils}/bin/sleep 5 130 ${pkgs.systemd}/bin/systemctl --user try-restart tray.target
130 ${pkgs.systemd}/bin/systemctl --user try-restart taffybar
131 ''; 131 '';
132 };
133 postswitch = {
134 # "restart-compton" = "${pkgs.systemd}/bin/systemctl --user try-restart picom";
135 "restart-tray" = ''
136 ${pkgs.systemd}/bin/systemctl --user try-restart tray.target
137 '';
138 };
132 }; 139 };
133 profiles = customUtils.nixImport { dir = ./autorandr-profiles; }; 140 profiles = customUtils.nixImport rec { dir = ./autorandr-profiles; _import = name: _base: import "${toString dir}/${name}" inputs; };
134 }; 141 };
135 142
136 zsh.initExtra = "source ${./zshrc}"; 143 zsh.initExtra = "source ${./zshrc}";