summaryrefslogtreecommitdiff
path: root/accounts/gkleen@sif/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/gkleen@sif/default.nix')
-rw-r--r--accounts/gkleen@sif/default.nix20
1 files changed, 15 insertions, 5 deletions
diff --git a/accounts/gkleen@sif/default.nix b/accounts/gkleen@sif/default.nix
index ca1ed77a..7df0235e 100644
--- a/accounts/gkleen@sif/default.nix
+++ b/accounts/gkleen@sif/default.nix
@@ -236,7 +236,7 @@ in {
236 enable = true; 236 enable = true;
237 font = { 237 font = {
238 package = pkgs.fira; 238 package = pkgs.fira;
239 name = "FiraMono Nerd Font"; 239 name = "Fira Mono";
240 size = 10; 240 size = 10;
241 }; 241 };
242 settings = { 242 settings = {
@@ -278,7 +278,7 @@ in {
278 output = "eDP-1"; 278 output = "eDP-1";
279 modules-left = [ "hyprland/workspaces" ]; 279 modules-left = [ "hyprland/workspaces" ];
280 modules-center = [ "hyprland/window" ]; 280 modules-center = [ "hyprland/window" ];
281 modules-right = [ "custom/weather" "custom/keymap" "privacy" "tray" "wireplumber" "backlight" "battery" "idle_inhibitor" "clock" ]; 281 modules-right = [ "custom/worktime" "custom/worktime-today" "custom/weather" "custom/keymap" "privacy" "tray" "wireplumber" "backlight" "battery" "idle_inhibitor" "clock" ];
282 282
283 "custom/weather" = { 283 "custom/weather" = {
284 format = "{}"; 284 format = "{}";
@@ -323,6 +323,16 @@ in {
323 ''; 323 '';
324 on-click = "hyprctl switchxkblayout at-translated-set-2-keyboard next"; 324 on-click = "hyprctl switchxkblayout at-translated-set-2-keyboard next";
325 }; 325 };
326 "custom/worktime" = {
327 interval = 60;
328 exec = getExe pkgs.worktime;
329 tooltip = false;
330 };
331 "custom/worktime-today" = {
332 interval = 60;
333 exec = "${getExe pkgs.worktime} today";
334 tooltip = false;
335 };
326 "hyprland/workspaces" = { 336 "hyprland/workspaces" = {
327 all-outputs = true; 337 all-outputs = true;
328 }; 338 };
@@ -473,14 +483,14 @@ in {
473 color: @red; 483 color: @red;
474 } 484 }
475 485
476 #custom-weather, #custom-keymap { 486 #custom-weather, #custom-keymap, #custom-worktime, #custom-worktime-today {
477 color: @grey; 487 color: @grey;
478 margin: 0 5px; 488 margin: 0 5px;
479 } 489 }
480 #custom-weather { 490 #custom-weather, #custom-worktime-today {
481 margin-right: 3px; 491 margin-right: 3px;
482 } 492 }
483 #custom-keymap { 493 #custom-keymap, #custom-weather {
484 margin-left: 3px; 494 margin-left: 3px;
485 } 495 }
486 496