summaryrefslogtreecommitdiff
path: root/accounts/gkleen@sif/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'accounts/gkleen@sif/default.nix')
-rw-r--r--accounts/gkleen@sif/default.nix12
1 files changed, 9 insertions, 3 deletions
diff --git a/accounts/gkleen@sif/default.nix b/accounts/gkleen@sif/default.nix
index 214b18a1..ed0de55b 100644
--- a/accounts/gkleen@sif/default.nix
+++ b/accounts/gkleen@sif/default.nix
@@ -163,7 +163,7 @@ in {
163 enable = true; 163 enable = true;
164 package = pkgs.emacs29-pgtk; 164 package = pkgs.emacs29-pgtk;
165 extraPackages = epkgs: with epkgs; [ 165 extraPackages = epkgs: with epkgs; [
166 evil evil-dvorak undo-tree magit haskell-mode nix-mode 166 evil evil-dvorak undo-tree magit haskell-tng-mode nix-mode
167 yaml-mode json-mode shakespeare-mode smart-mode-line 167 yaml-mode json-mode shakespeare-mode smart-mode-line
168 highlight-parentheses highlight-symbol ag sass-mode lua-mode 168 highlight-parentheses highlight-symbol ag sass-mode lua-mode
169 fira-code-mode use-package wanderlust # notmuch 169 fira-code-mode use-package wanderlust # notmuch
@@ -171,6 +171,7 @@ in {
171 edit-server mediawiki editorconfig typescript-mode 171 edit-server mediawiki editorconfig typescript-mode
172 markdown-mode nftables-mode rustic lsp-mode lsp-ui 172 markdown-mode nftables-mode rustic lsp-mode lsp-ui
173 direnv company projectile tomorrow-night-paradise-theme 173 direnv company projectile tomorrow-night-paradise-theme
174 treesit-grammars.with-all-grammars
174 ]; 175 ];
175 overrides = self: super: { 176 overrides = self: super: {
176 tomorrow-night-paradise-theme = super.trivialBuild { 177 tomorrow-night-paradise-theme = super.trivialBuild {
@@ -558,7 +559,7 @@ in {
558 socketActivation.enable = true; 559 socketActivation.enable = true;
559 client = { 560 client = {
560 enable = true; 561 enable = true;
561 arguments = mkForce ["-a" "\"\""]; 562 arguments = mkForce ["--reuse-frame" "--alternate-editor" "\"\""];
562 }; 563 };
563 }; 564 };
564 gpg-agent = { 565 gpg-agent = {
@@ -693,7 +694,7 @@ in {
693 ]; 694 ];
694 695
695 file = { 696 file = {
696 ".emacs".source = ./emacs.el; 697 ".emacs.d/init.el".source = ./emacs.el;
697 ".backup-munin".source = ./backup-patterns; 698 ".backup-munin".source = ./backup-patterns;
698 ".mozilla/firefox/default/chrome/userChrome.css".source = ./firefox-chrome.css; 699 ".mozilla/firefox/default/chrome/userChrome.css".source = ./firefox-chrome.css;
699 ".mozilla/firefox/default/chrome/userContent.css".source = ./firefox-content.css; 700 ".mozilla/firefox/default/chrome/userContent.css".source = ./firefox-content.css;
@@ -711,6 +712,11 @@ in {
711 QT_QPA_PLATFORMTHEME = "qt5ct"; 712 QT_QPA_PLATFORMTHEME = "qt5ct";
712 LIBVIRT_DEFAULT_URI = "qemu:///system"; 713 LIBVIRT_DEFAULT_URI = "qemu:///system";
713 STACK_XDG = 1; 714 STACK_XDG = 1;
715 EDITOR = pkgs.writeShellScript "editor" ''
716 args=("--reuse-frame" "--alternate-editor" "")
717 args+=("$@")
718 exec -a emacsclient ${cfg.services.emacs.package}/bin/emacsclient "''${args[@]}"
719 '';
714 }; 720 };
715 721
716 extraProfileCommands = '' 722 extraProfileCommands = ''