summaryrefslogtreecommitdiff
path: root/ymir.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2015-09-30 23:01:43 +0200
committerGregor Kleen <gkleen@yggdrasil.li>2015-09-30 23:01:43 +0200
commit3afe0d55c4124d3cf45c2bf5d499a5cfec18c339 (patch)
tree8761be158ba497732fac156c7722df2089e12b0d /ymir.nix
parentbb03185103072af86d4e196aac06beec4869dac6 (diff)
downloadnixos-3afe0d55c4124d3cf45c2bf5d499a5cfec18c339.tar
nixos-3afe0d55c4124d3cf45c2bf5d499a5cfec18c339.tar.gz
nixos-3afe0d55c4124d3cf45c2bf5d499a5cfec18c339.tar.bz2
nixos-3afe0d55c4124d3cf45c2bf5d499a5cfec18c339.tar.xz
nixos-3afe0d55c4124d3cf45c2bf5d499a5cfec18c339.zip
Syntax
Diffstat (limited to 'ymir.nix')
-rw-r--r--ymir.nix19
1 files changed, 9 insertions, 10 deletions
diff --git a/ymir.nix b/ymir.nix
index a00873f4..72f85ad5 100644
--- a/ymir.nix
+++ b/ymir.nix
@@ -5,6 +5,14 @@ let
5 luaPosix = pkgs.callPackage ./custom/luaPosix.nix {}; 5 luaPosix = pkgs.callPackage ./custom/luaPosix.nix {};
6 luaSha2 = pkgs.callPackage ./custom/luaSha2.nix {}; 6 luaSha2 = pkgs.callPackage ./custom/luaSha2.nix {};
7 prosodyAuth = pkgs.callPackage ./custom/prosody-auth.nix {}; 7 prosodyAuth = pkgs.callPackage ./custom/prosody-auth.nix {};
8 prosodyVirtHost = name: {
9 enabled = true;
10 domain = name;
11 ssl = {
12 key = "certs/${name}.key";
13 cert = "certs/${name}.crt";
14 };
15 };
8in { 16in {
9 imports = 17 imports =
10 [ 18 [
@@ -108,16 +116,7 @@ in {
108 custom_alias_secret_file="/etc/prosody/alias_secret" 116 custom_alias_secret_file="/etc/prosody/alias_secret"
109 ''; 117 '';
110 118
111 let 119 virtualHosts = builtins.listToAttrs (name: { inherit name; value = prosodyVirtHost name; })
112 makeHost = name: {
113 enabled = true;
114 domain = name;
115 ssl = {
116 key = "certs/${name}.key";
117 cert = "certs/${name}.crt";
118 };
119 };
120 in virtualHosts = builtins.listToAttrs (name: { inherit name; value = makeHost name; })
121 ["xmpp.li" "yggdrasil.li" "praseodym.org" "141.li"]; 120 ["xmpp.li" "yggdrasil.li" "praseodym.org" "141.li"];
122 }; 121 };
123 security.pam.services."xmpp".text = '' 122 security.pam.services."xmpp".text = ''