diff options
author | Gregor Kleen <gkleen@yggdrasil.li> | 2016-01-13 01:39:11 +0100 |
---|---|---|
committer | Gregor Kleen <gkleen@yggdrasil.li> | 2016-01-13 01:39:11 +0100 |
commit | 0da1c1ce3bfb134fb9d9eff6faf2b386f8d50d3d (patch) | |
tree | ca125bfb28deb7d4eda70f33ffe7bbe51c3ca63e /ymir.nix | |
parent | 3f8e58df65f96650b3091e9040b44f603b4526e7 (diff) | |
download | nixos-0da1c1ce3bfb134fb9d9eff6faf2b386f8d50d3d.tar nixos-0da1c1ce3bfb134fb9d9eff6faf2b386f8d50d3d.tar.gz nixos-0da1c1ce3bfb134fb9d9eff6faf2b386f8d50d3d.tar.bz2 nixos-0da1c1ce3bfb134fb9d9eff6faf2b386f8d50d3d.tar.xz nixos-0da1c1ce3bfb134fb9d9eff6faf2b386f8d50d3d.zip |
first stab at customized uwsgi
Diffstat (limited to 'ymir.nix')
-rw-r--r-- | ymir.nix | 13 |
1 files changed, 13 insertions, 0 deletions
@@ -43,6 +43,19 @@ in rec { | |||
43 | extraModules = [prosodyAuth]; | 43 | extraModules = [prosodyAuth]; |
44 | extraLibs = [luaPam luaPosix luaSha2]; | 44 | extraLibs = [luaPam luaPosix luaSha2]; |
45 | }); | 45 | }); |
46 | uwsgi = pkgs.callPackage ./customized/uwsgi.nix { | ||
47 | extraPlugins = [ | ||
48 | { name = "cgi"; | ||
49 | interpreter = pkgs.python3; | ||
50 | path = "plugins/cgi"; | ||
51 | deps = [ pkgs.python3 ]; | ||
52 | install = '' | ||
53 | ${pkgs.python3.executable} -m compileall $out/${pkgs.python3.sitePackages}/ | ||
54 | ${pkgs.python3.executable} -O -m compileall $out/${pkgs.pytho3.sitePackages}/ | ||
55 | ''; | ||
56 | } | ||
57 | ]; | ||
58 | }; | ||
46 | }; | 59 | }; |
47 | 60 | ||
48 | environment.systemPackages = with pkgs; [ | 61 | environment.systemPackages = with pkgs; [ |