summaryrefslogtreecommitdiff
path: root/vali.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@praseodym.org>2015-07-03 17:25:10 +0200
committerGregor Kleen <gkleen@praseodym.org>2015-07-03 17:25:10 +0200
commite9f8f3473067368451cd47737bd52142b71cc49c (patch)
tree3b8fe3cc9e19eb5f79439de13a367b4c4f104486 /vali.nix
parentde1d5fc09b34d86386888648b18951c1aca3b8f7 (diff)
downloadnixos-e9f8f3473067368451cd47737bd52142b71cc49c.tar
nixos-e9f8f3473067368451cd47737bd52142b71cc49c.tar.gz
nixos-e9f8f3473067368451cd47737bd52142b71cc49c.tar.bz2
nixos-e9f8f3473067368451cd47737bd52142b71cc49c.tar.xz
nixos-e9f8f3473067368451cd47737bd52142b71cc49c.zip
Ran nixos-generate-config on Vali
Diffstat (limited to 'vali.nix')
-rw-r--r--vali.nix59
1 files changed, 59 insertions, 0 deletions
diff --git a/vali.nix b/vali.nix
new file mode 100644
index 00000000..feabb1ec
--- /dev/null
+++ b/vali.nix
@@ -0,0 +1,59 @@
1# Edit this configuration file to define what should be installed on
2# your system. Help is available in the configuration.nix(5) man page
3# and in the NixOS manual (accessible by running ‘nixos-help’).
4
5{ config, pkgs, ... }:
6
7{
8 imports =
9 [ # Include the results of the hardware scan.
10 ./hardware-configuration.nix
11 ];
12
13 # Use the GRUB 2 boot loader.
14 boot.loader.grub.enable = true;
15 boot.loader.grub.version = 2;
16 # Define on which hard drive you want to install Grub.
17 # boot.loader.grub.device = "/dev/sda";
18
19 # networking.hostName = "nixos"; # Define your hostname.
20 networking.hostId = "03dda86d";
21 # networking.wireless.enable = true; # Enables wireless.
22
23 # Select internationalisation properties.
24 # i18n = {
25 # consoleFont = "lat9w-16";
26 # consoleKeyMap = "us";
27 # defaultLocale = "en_US.UTF-8";
28 # };
29
30 # List packages installed in system profile. To search by name, run:
31 # $ nix-env -qaP | grep wget
32 # environment.systemPackages = with pkgs; [
33 # wget
34 # ];
35
36 # List services that you want to enable:
37
38 # Enable the OpenSSH daemon.
39 # services.openssh.enable = true;
40
41 # Enable CUPS to print documents.
42 # services.printing.enable = true;
43
44 # Enable the X11 windowing system.
45 # services.xserver.enable = true;
46 # services.xserver.layout = "us";
47 # services.xserver.xkbOptions = "eurosign:e";
48
49 # Enable the KDE Desktop Environment.
50 # services.xserver.displayManager.kdm.enable = true;
51 # services.xserver.desktopManager.kde4.enable = true;
52
53 # Define a user account. Don't forget to set a password with ‘passwd’.
54 # users.extraUsers.guest = {
55 # isNormalUser = true;
56 # uid = 1000;
57 # };
58
59}