diff options
author | Gregor Kleen <gkleen@yggdrasil.li> | 2021-11-17 06:44:09 +0059 |
---|---|---|
committer | Gregor Kleen <gkleen@yggdrasil.li> | 2021-11-17 06:44:09 +0059 |
commit | e76a654ce960d190c53339f2290906b6736dee60 (patch) | |
tree | c81943b24c82a447bcc7ae4645477146b2e059be /overlays/pidgin.nix | |
parent | 85ecd1a65123cce94e634dc41c342a1d02f43c06 (diff) | |
download | nixos-e76a654ce960d190c53339f2290906b6736dee60.tar nixos-e76a654ce960d190c53339f2290906b6736dee60.tar.gz nixos-e76a654ce960d190c53339f2290906b6736dee60.tar.bz2 nixos-e76a654ce960d190c53339f2290906b6736dee60.tar.xz nixos-e76a654ce960d190c53339f2290906b6736dee60.zip |
bump versions
Diffstat (limited to 'overlays/pidgin.nix')
-rw-r--r-- | overlays/pidgin.nix | 23 |
1 files changed, 22 insertions, 1 deletions
diff --git a/overlays/pidgin.nix b/overlays/pidgin.nix index d346c7a1..3c9fb93c 100644 --- a/overlays/pidgin.nix +++ b/overlays/pidgin.nix | |||
@@ -4,8 +4,29 @@ let | |||
4 | url = "https://developer.pidgin.im/raw-attachment/ticket/16524/0001-only-request-unseed-chat-history-from-jabber-group-c.patch"; | 4 | url = "https://developer.pidgin.im/raw-attachment/ticket/16524/0001-only-request-unseed-chat-history-from-jabber-group-c.patch"; |
5 | sha256 = "083wvmq7417xz55fxxhllqwql1hgjvin2sak08844121yw1jvc44"; | 5 | sha256 = "083wvmq7417xz55fxxhllqwql1hgjvin2sak08844121yw1jvc44"; |
6 | }; | 6 | }; |
7 | |||
8 | pidginWrapper = { symlinkJoin, pidgin, makeWrapper, plugins }: | ||
9 | let | ||
10 | extraArgs = map (x: x.wrapArgs or "") plugins; | ||
11 | majorVersion = prev.lib.versions.major pidgin.version; | ||
12 | in symlinkJoin { | ||
13 | name = "pidgin-with-plugins-${pidgin.version}"; | ||
14 | |||
15 | paths = [ pidgin ] ++ plugins; | ||
16 | |||
17 | buildInputs = [ makeWrapper ]; | ||
18 | |||
19 | postBuild = '' | ||
20 | wrapProgram $out/bin/pidgin \ | ||
21 | --suffix-each PURPLE_PLUGIN_PATH ':' "$out/lib/purple-${majorVersion} $out/lib/pidgin" \ | ||
22 | ${toString extraArgs} | ||
23 | wrapProgram $out/bin/finch \ | ||
24 | --suffix-each PURPLE_PLUGIN_PATH ':' "$out/lib/purple-${majorVersion}" \ | ||
25 | ${toString extraArgs} | ||
26 | ''; | ||
27 | }; | ||
7 | in { | 28 | in { |
8 | pidgin-with-plugins = import (/. + prev.path + "/pkgs/applications/networking/instant-messengers/pidgin/wrapper.nix") { | 29 | pidgin-with-plugins = pidginWrapper { |
9 | inherit (prev) makeWrapper symlinkJoin; | 30 | inherit (prev) makeWrapper symlinkJoin; |
10 | plugins = with final; [ purple-lurch pidgin-carbons pidgin-opensteamworks pidgin-xmpp-receipts ]; | 31 | plugins = with final; [ purple-lurch pidgin-carbons pidgin-opensteamworks pidgin-xmpp-receipts ]; |
11 | pidgin = prev.pidgin.overrideAttrs (oldAttrs: { | 32 | pidgin = prev.pidgin.overrideAttrs (oldAttrs: { |