summaryrefslogtreecommitdiff
path: root/overlays/matrix-synapse/1.70.1/plugins/shared-secret-auth.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2022-11-07 20:51:39 +0100
committerGregor Kleen <gkleen@yggdrasil.li>2022-11-07 20:51:39 +0100
commit0e9f1e85cd8c6f9d546ef88e971043b909017170 (patch)
tree5cb4d14df7594ef123f20d82cb2ec423b6bca744 /overlays/matrix-synapse/1.70.1/plugins/shared-secret-auth.nix
parentf563ddece04adfd8d80d4e984405f5c70a6c94f3 (diff)
downloadnixos-0e9f1e85cd8c6f9d546ef88e971043b909017170.tar
nixos-0e9f1e85cd8c6f9d546ef88e971043b909017170.tar.gz
nixos-0e9f1e85cd8c6f9d546ef88e971043b909017170.tar.bz2
nixos-0e9f1e85cd8c6f9d546ef88e971043b909017170.tar.xz
nixos-0e9f1e85cd8c6f9d546ef88e971043b909017170.zip
...
Diffstat (limited to 'overlays/matrix-synapse/1.70.1/plugins/shared-secret-auth.nix')
-rw-r--r--overlays/matrix-synapse/1.70.1/plugins/shared-secret-auth.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/overlays/matrix-synapse/1.70.1/plugins/shared-secret-auth.nix b/overlays/matrix-synapse/1.70.1/plugins/shared-secret-auth.nix
new file mode 100644
index 00000000..a6e22db3
--- /dev/null
+++ b/overlays/matrix-synapse/1.70.1/plugins/shared-secret-auth.nix
@@ -0,0 +1,26 @@
1{ lib, buildPythonPackage, fetchFromGitHub, matrix-synapse, twisted }:
2
3buildPythonPackage rec {
4 pname = "matrix-synapse-shared-secret-auth";
5 version = "2.0.2";
6
7 src = fetchFromGitHub {
8 owner = "devture";
9 repo = "matrix-synapse-shared-secret-auth";
10 rev = version;
11 sha256 = "sha256-qzXKwTEOMtdvsxoU3Xh3vQyhK+Q18LfkeSts7EyDIXE=";
12 };
13
14 doCheck = false;
15 pythonImportsCheck = [ "shared_secret_authenticator" ];
16
17 buildInputs = [ matrix-synapse ];
18 propagatedBuildInputs = [ twisted ];
19
20 meta = with lib; {
21 description = "Shared Secret Authenticator password provider module for Matrix Synapse";
22 homepage = "https://github.com/devture/matrix-synapse-shared-secret-auth";
23 license = licenses.agpl3Plus;
24 maintainers = with maintainers; [ sumnerevans ];
25 };
26}