summaryrefslogtreecommitdiff
path: root/overlays/matrix-synapse/1.70.1/plugins/mjolnir-antispam.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2022-11-07 20:51:39 +0100
committerGregor Kleen <gkleen@yggdrasil.li>2022-11-07 20:51:39 +0100
commit0e9f1e85cd8c6f9d546ef88e971043b909017170 (patch)
tree5cb4d14df7594ef123f20d82cb2ec423b6bca744 /overlays/matrix-synapse/1.70.1/plugins/mjolnir-antispam.nix
parentf563ddece04adfd8d80d4e984405f5c70a6c94f3 (diff)
downloadnixos-0e9f1e85cd8c6f9d546ef88e971043b909017170.tar
nixos-0e9f1e85cd8c6f9d546ef88e971043b909017170.tar.gz
nixos-0e9f1e85cd8c6f9d546ef88e971043b909017170.tar.bz2
nixos-0e9f1e85cd8c6f9d546ef88e971043b909017170.tar.xz
nixos-0e9f1e85cd8c6f9d546ef88e971043b909017170.zip
...
Diffstat (limited to 'overlays/matrix-synapse/1.70.1/plugins/mjolnir-antispam.nix')
-rw-r--r--overlays/matrix-synapse/1.70.1/plugins/mjolnir-antispam.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/overlays/matrix-synapse/1.70.1/plugins/mjolnir-antispam.nix b/overlays/matrix-synapse/1.70.1/plugins/mjolnir-antispam.nix
new file mode 100644
index 00000000..7372c2f7
--- /dev/null
+++ b/overlays/matrix-synapse/1.70.1/plugins/mjolnir-antispam.nix
@@ -0,0 +1,32 @@
1{ lib, buildPythonPackage, fetchFromGitHub, matrix-synapse }:
2
3buildPythonPackage rec {
4 pname = "matrix-synapse-mjolnir-antispam";
5 version = "1.5.0";
6
7 src = fetchFromGitHub {
8 owner = "matrix-org";
9 repo = "mjolnir";
10 rev = "refs/tags/v${version}";
11 sha256 = "sha256-YmP+r9W5e63Aw66lSQeTTbYwSF/vjPyHkoehJxtcRNw=";
12 };
13
14 sourceRoot = "./source/synapse_antispam";
15
16 propagatedBuildInputs = [ matrix-synapse ];
17
18 doCheck = false; # no tests
19 pythonImportsCheck = [ "mjolnir" ];
20
21 meta = with lib; {
22 description = "AntiSpam / Banlist plugin to be used with mjolnir";
23 longDescription = ''
24 Primarily meant to block invites from undesired homeservers/users,
25 Mjolnir's Synapse module is a way to interpret ban lists and apply
26 them to your entire homeserver.
27 '';
28 homepage = "https://github.com/matrix-org/mjolnir#synapse-module";
29 license = licenses.asl20;
30 maintainers = with maintainers; [ jojosch ];
31 };
32}