summaryrefslogtreecommitdiff
path: root/odin.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2018-04-05 15:14:04 +0200
committerGregor Kleen <gkleen@yggdrasil.li>2018-04-05 15:14:04 +0200
commitfa86af83d2967aae493394f4d54da4f8182d68b8 (patch)
treebab0f5935c2da18ff3b866f3f709589faa53f233 /odin.nix
parent754b0d8ab9b2db42a6f2107b2519fdeb7db424f4 (diff)
downloadnixos-fa86af83d2967aae493394f4d54da4f8182d68b8.tar
nixos-fa86af83d2967aae493394f4d54da4f8182d68b8.tar.gz
nixos-fa86af83d2967aae493394f4d54da4f8182d68b8.tar.bz2
nixos-fa86af83d2967aae493394f4d54da4f8182d68b8.tar.xz
nixos-fa86af83d2967aae493394f4d54da4f8182d68b8.zip
Accept mail on odin
Diffstat (limited to 'odin.nix')
-rw-r--r--odin.nix21
1 files changed, 20 insertions, 1 deletions
diff --git a/odin.nix b/odin.nix
index 44052d46..1f2a6658 100644
--- a/odin.nix
+++ b/odin.nix
@@ -103,7 +103,22 @@
103 networksStyle = "host"; 103 networksStyle = "host";
104 hostname = "odin.asgard.yggdrasil"; 104 hostname = "odin.asgard.yggdrasil";
105 recipientDelimiter = "+"; 105 recipientDelimiter = "+";
106 postmasterAlias = ""; rootAlias = ""; extraAliases = ""; 106 postmasterAlias = "gkleen";
107 rootAlias = "gkleen";
108
109 destination = [''regexp:${pkgs.writeText "destination" ''
110 /\.?yggdrasil\.li$/ ACCEPT
111 /\.?praseodym\.org$/ ACCEPT
112 /\.?141\.li$/ ACCEPT
113 /\.?xmpp\.li$/ ACCEPT
114 /\.?kleen\.li$/ ACCEPT
115 /\.?dirty-haskell\.org$/ ACCEPT
116 /\.?nights\.email$/ ACCEPT
117 /\.?yggdrasil$/ ACCEPT
118 /\.?localdomain$/ ACCEPT
119 /^localhost$/ ACCEPT
120 /\.?odin$/ ACCEPT
121 ''}''];
107 122
108 config = { 123 config = {
109 default_transport = "uucp:ymir"; 124 default_transport = "uucp:ymir";
@@ -111,6 +126,8 @@
111 message_size_limit = "0"; 126 message_size_limit = "0";
112 127
113 mail_spool_directory = "/srv/mail"; 128 mail_spool_directory = "/srv/mail";
129
130 luser_relay = "postmaster${recipient_delimiter}${local:unknown}";
114 }; 131 };
115 132
116 masterConfig = { 133 masterConfig = {
@@ -123,6 +140,8 @@
123 args = [ "flags=Fqhu" "user=uucp" ''argv=${config.security.wrapperDir}/uux -z -a $sender - $nexthop!rmail ($recipient)'' ]; 140 args = [ "flags=Fqhu" "user=uucp" ''argv=${config.security.wrapperDir}/uux -z -a $sender - $nexthop!rmail ($recipient)'' ];
124 }; 141 };
125 }; 142 };
143
144 networks = ["127.0.0.0/8" "[::ffff:127.0.0.0]/104" "[::1]/128" "10.141.0.0/16"];
126 }; 145 };
127 146
128 system.autoUpgrade.enable = true; 147 system.autoUpgrade.enable = true;