summaryrefslogtreecommitdiff
path: root/jack2.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2015-06-07 14:37:03 +0200
committerGregor Kleen <gkleen@yggdrasil.li>2015-06-07 14:37:03 +0200
commit63644513486213a25d31226856158a4a77fc21cd (patch)
treebf6e3ee2f558bcd370d535cc59bda188ab2c705f /jack2.nix
parentff6e375086a573fc1ba3473ea4ccd577ec11b702 (diff)
downloadnixos-63644513486213a25d31226856158a4a77fc21cd.tar
nixos-63644513486213a25d31226856158a4a77fc21cd.tar.gz
nixos-63644513486213a25d31226856158a4a77fc21cd.tar.bz2
nixos-63644513486213a25d31226856158a4a77fc21cd.tar.xz
nixos-63644513486213a25d31226856158a4a77fc21cd.zip
Patched jack2 (no dbus)
Diffstat (limited to 'jack2.nix')
-rw-r--r--jack2.nix45
1 files changed, 45 insertions, 0 deletions
diff --git a/jack2.nix b/jack2.nix
new file mode 100644
index 00000000..289a3986
--- /dev/null
+++ b/jack2.nix
@@ -0,0 +1,45 @@
1{ stdenv, fetchurl, alsaLib, expat, libsamplerate
2, libsndfile, makeWrapper, pkgconfig, python
3, firewireSupport ? false, ffado ? null, bash }:
4
5assert firewireSupport -> ffado != null;
6
7stdenv.mkDerivation rec {
8 name = "jack2-${version}";
9 version = "1.9.10";
10
11 src = fetchurl {
12 urls = [
13 https://github.com/jackaudio/jack2/archive/v1.9.10.tar.gz
14 ];
15 sha256 = "03b0iiyk3ng3vh5s8gaqwn565vik7910p56mlbk512bw3dhbdwc8";
16 };
17
18 buildInputs =
19 [ alsaLib dbus expat libsamplerate libsndfile makeWrapper
20 pkgconfig python pythonDBus
21 ] ++ (stdenv.lib.optional firewireSupport ffado);
22
23 patchPhase = ''
24 substituteInPlace svnversion_regenerate.sh --replace /bin/bash ${bash}/bin/bash
25 '';
26
27 configurePhase = ''
28 python waf configure --prefix=$out --alsa ${if firewireSupport then "--firewire" else ""}
29 '';
30
31 buildPhase = "python waf build";
32
33 installPhase = ''
34 python waf install
35 wrapProgram $out/bin/jack_control --set PYTHONPATH $PYTHONPATH
36 '';
37
38 meta = with stdenv.lib; {
39 description = "JACK audio connection kit, version 2 with jackdbus";
40 homepage = "http://jackaudio.org";
41 license = licenses.gpl2Plus;
42 platforms = platforms.linux;
43 maintainers = [ maintainers.goibhniu ];
44 };
45}