summaryrefslogtreecommitdiff
path: root/hel.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2018-06-02 17:58:57 +0200
committerGregor Kleen <gkleen@yggdrasil.li>2018-06-02 17:58:57 +0200
commitd49dd672463aff72bd754d657abbd11cf8a0d8e0 (patch)
tree87f2c40733ec18528a518013f84e2dd523d15f66 /hel.nix
parent329245b4e3b9a2a9bbf7afd4570d7da311c58a42 (diff)
downloadnixos-d49dd672463aff72bd754d657abbd11cf8a0d8e0.tar
nixos-d49dd672463aff72bd754d657abbd11cf8a0d8e0.tar.gz
nixos-d49dd672463aff72bd754d657abbd11cf8a0d8e0.tar.bz2
nixos-d49dd672463aff72bd754d657abbd11cf8a0d8e0.tar.xz
nixos-d49dd672463aff72bd754d657abbd11cf8a0d8e0.zip
revamp uucp-mediaclient
Diffstat (limited to 'hel.nix')
-rw-r--r--hel.nix22
1 files changed, 11 insertions, 11 deletions
diff --git a/hel.nix b/hel.nix
index 423f90bd..efc58b8f 100644
--- a/hel.nix
+++ b/hel.nix
@@ -15,6 +15,8 @@
15 ./custom/tinc/yggdrasil.nix 15 ./custom/tinc/yggdrasil.nix
16 ./custom/uucp.nix 16 ./custom/uucp.nix
17 ./custom/borgbackup.nix 17 ./custom/borgbackup.nix
18 ./custom/uucp-mediaclient.nix
19 ./custom/notify-users.nix
18 ./utils/nix/module.nix 20 ./utils/nix/module.nix
19 ]; 21 ];
20 22
@@ -214,7 +216,7 @@
214 "odin" = { 216 "odin" = {
215 publicKeys = ["ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIKcDj49TqmflGTmtGBqDawxmCBWW1txj61CZ7KT0hTHK uucp@odin"]; 217 publicKeys = ["ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIKcDj49TqmflGTmtGBqDawxmCBWW1txj61CZ7KT0hTHK uucp@odin"];
216 hostnames = ["odin.asgard.yggdrasil"]; 218 hostnames = ["odin.asgard.yggdrasil"];
217 commands = lib.mkForce ["recv-media" "notify-gkleen"]; 219 commands = ["notify-gkleen"];
218 }; 220 };
219 "ymir" = { 221 "ymir" = {
220 publicKeys = ["ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIFH1QWdgoC03nzW5GBuCl2pqASHeIXIYtE9IInHdaKcO uucp@ymir"]; 222 publicKeys = ["ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIFH1QWdgoC03nzW5GBuCl2pqASHeIXIYtE9IInHdaKcO uucp@ymir"];
@@ -222,9 +224,16 @@
222 }; 224 };
223 }; 225 };
224 226
225 commandPath = [ "${pkgs.callPackage ./hel/recv-media.nix {}}/bin" config.security.wrapperDir ]; 227 commandPath = [ "${config.security.wrapperDir}" ];
226 defaultCommands = lib.mkForce []; 228 defaultCommands = lib.mkForce [];
229
230 media-client = {
231 remoteNodes = [ "odin" ];
232 notify.users = [ "gkleen" ];
233 };
227 }; 234 };
235
236 notify-users = [ "gkleen" ];
228 237
229 postfix = { 238 postfix = {
230 enable = true; 239 enable = true;
@@ -357,15 +366,6 @@
357 "mount.cifs".source = "${pkgs.cifs-utils}/bin/mount.cifs"; 366 "mount.cifs".source = "${pkgs.cifs-utils}/bin/mount.cifs";
358 "thinklight".source = 367 "thinklight".source =
359 "${(pkgs.callPackage ./custom/thinklight.nix { thinklight = "kbd_backlight"; })}/bin/thinklight"; 368 "${(pkgs.callPackage ./custom/thinklight.nix { thinklight = "kbd_backlight"; })}/bin/thinklight";
360 "notify-gkleen" = {
361 group = "users";
362 owner = "gkleen";
363 setgid = true;
364 setuid = true;
365 permissions = "u+rx,g+x,o+x";
366 source = let notify-user = pkgs.callPackage ./custom/notify-user.nix { inherit (pkgs.haskellPackages) ghcWithPackages; };
367 in "${notify-user}/bin/notify-gkleen";
368 };
369 }; 369 };
370 370
371 polkit = { 371 polkit = {