summaryrefslogtreecommitdiff
path: root/hel.nix
diff options
context:
space:
mode:
authorGregor Kleen <pngwjpgh@users.noreply.github.com>2017-01-20 11:07:35 +0100
committerGregor Kleen <pngwjpgh@users.noreply.github.com>2017-01-20 11:07:35 +0100
commitb0804cf12042f912b2fe65482d431506bf2c8549 (patch)
tree50771a74e9c29e872ea344fb61dff90928b04bd5 /hel.nix
parente3de8e2dfafc5e29e91b48e3d8cfed214987f33e (diff)
downloadnixos-b0804cf12042f912b2fe65482d431506bf2c8549.tar
nixos-b0804cf12042f912b2fe65482d431506bf2c8549.tar.gz
nixos-b0804cf12042f912b2fe65482d431506bf2c8549.tar.bz2
nixos-b0804cf12042f912b2fe65482d431506bf2c8549.tar.xz
nixos-b0804cf12042f912b2fe65482d431506bf2c8549.zip
services.dbus instead of users.dbus
Diffstat (limited to 'hel.nix')
-rw-r--r--hel.nix40
1 files changed, 20 insertions, 20 deletions
diff --git a/hel.nix b/hel.nix
index 1f8f892f..dcd56456 100644
--- a/hel.nix
+++ b/hel.nix
@@ -288,6 +288,26 @@
288 localuser = null; 288 localuser = null;
289 prunePaths = ["/tmp" "/var/tmp" "/var/cache" "/var/lock" "/var/run" "/var/spool"]; 289 prunePaths = ["/tmp" "/var/tmp" "/var/cache" "/var/lock" "/var/run" "/var/spool"];
290 }; 290 };
291
292 dbus = {
293 enable = true;
294 packages = [ (pkgs.writeTextFile {
295 name = "eavesdrop.conf";
296 text = ''
297 <!DOCTYPE busconfig PUBLIC
298 "-//freedesktop//DTD D-Bus Bus Configuration 1.0//EN"
299 "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
300 <busconfig>
301 <policy user="root">
302 <allow eavesdrop="true"/>
303 <allow eavesdrop="true" send_destination="*"/>
304 </policy>
305 </busconfig>
306 '';
307 destination = "/etc/dbus-1/system.d/eavesdrop.conf";
308 })
309 ];
310 };
291 }; 311 };
292 312
293 users = { 313 users = {
@@ -319,26 +339,6 @@
319 members = [ "gkleen" ]; 339 members = [ "gkleen" ];
320 }; 340 };
321 }; 341 };
322
323 dbus = {
324 enable = true;
325 packages = [ (pkgs.writeTextFile {
326 name = "eavesdrop.conf";
327 text = ''
328 <!DOCTYPE busconfig PUBLIC
329 "-//freedesktop//DTD D-Bus Bus Configuration 1.0//EN"
330 "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
331 <busconfig>
332 <policy user="root">
333 <allow eavesdrop="true"/>
334 <allow eavesdrop="true" send_destination="*"/>
335 </policy>
336 </busconfig>
337 '';
338 destination = "/etc/dbus-1/system.d/eavesdrop.conf";
339 })
340 ];
341 };
342 }; 342 };
343 343
344 security = { 344 security = {