summaryrefslogtreecommitdiff
path: root/hel.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2018-04-30 14:57:16 +0200
committerGregor Kleen <gkleen@yggdrasil.li>2018-04-30 14:57:16 +0200
commit1179681099b6da88c100d5f2cc9244acaee49f8a (patch)
treec85fe5b58849ce229fd43ddb9a6924ca066cbd0f /hel.nix
parente58370464efbe2672246610c88e91dd28afa6cfb (diff)
downloadnixos-1179681099b6da88c100d5f2cc9244acaee49f8a.tar
nixos-1179681099b6da88c100d5f2cc9244acaee49f8a.tar.gz
nixos-1179681099b6da88c100d5f2cc9244acaee49f8a.tar.bz2
nixos-1179681099b6da88c100d5f2cc9244acaee49f8a.tar.xz
nixos-1179681099b6da88c100d5f2cc9244acaee49f8a.zip
samba stuff
Diffstat (limited to 'hel.nix')
-rw-r--r--hel.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/hel.nix b/hel.nix
index cc4698cc..024429f0 100644
--- a/hel.nix
+++ b/hel.nix
@@ -556,5 +556,37 @@
556 MemoryHigh = "50%"; 556 MemoryHigh = "50%";
557 MemoryMax = "75%"; 557 MemoryMax = "75%";
558 }; 558 };
559
560 services.samba = {
561 enable = true;
562 extraConfig = ''
563 domain master = no
564 workgroup = ASGARD
565 load printers = no
566 printing = bsd
567 printcap name = /dev/null
568 disable spoolss = yes
569 '';
570 };
571
572 systemd.mounts = [
573 {
574 where = "/media";
575 what = "\\\\odin.asgard.yggdrasil\\media";
576 type = "cifs";
577 options = lib.concatStringsSep ","
578 [ "guest"
579 ];
580 }
581 ];
582
583 systemd.automounts = [
584 {
585 where = "/media";
586 automountConfig = {
587 TimeoutIdleSec = "5min";
588 };
589 }
590 ];
559} 591}
560 592