summaryrefslogtreecommitdiff
path: root/hel.nix
diff options
context:
space:
mode:
authorGregor Kleen <pngwjpgh@users.noreply.github.com>2016-10-06 17:35:21 +0200
committerGregor Kleen <pngwjpgh@users.noreply.github.com>2016-10-06 17:35:21 +0200
commit0e4a3eaac8ec0af33963e97a1b6ba1a941649762 (patch)
treec38ad2ed986afb8c79eca90e9cc572b9a29109f2 /hel.nix
parent3d0adb1b8c2173b781c91aafa7aa2abdfe1b36c6 (diff)
downloadnixos-0e4a3eaac8ec0af33963e97a1b6ba1a941649762.tar
nixos-0e4a3eaac8ec0af33963e97a1b6ba1a941649762.tar.gz
nixos-0e4a3eaac8ec0af33963e97a1b6ba1a941649762.tar.bz2
nixos-0e4a3eaac8ec0af33963e97a1b6ba1a941649762.tar.xz
nixos-0e4a3eaac8ec0af33963e97a1b6ba1a941649762.zip
kill uucp before sleep
Diffstat (limited to 'hel.nix')
-rw-r--r--hel.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/hel.nix b/hel.nix
index 89b39708..718ddf53 100644
--- a/hel.nix
+++ b/hel.nix
@@ -358,6 +358,17 @@
358 wants = [ "slimlock@gkleen.service" ]; 358 wants = [ "slimlock@gkleen.service" ];
359 }; 359 };
360 360
361 systemd.services."kill-user@" = {
362 serviceConfig = {
363 Type = "oneshot";
364 ExecStart = "${pkgs.systemd}/bin/loginctl kill-user %I";
365 };
366 };
367 systemd.targets."sleep" = {
368 after = [ "kill-user@uucp.service" ];
369 wants = [ "kill-user@uucp.service" ];
370 };
371
361 virtualisation.virtualbox.host = { 372 virtualisation.virtualbox.host = {
362 enable = true; 373 enable = true;
363 }; 374 };