summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2022-03-18 09:34:09 +0100
committerGregor Kleen <gkleen@yggdrasil.li>2022-03-18 09:34:09 +0100
commitfafc831d6be643ea184d117b2c8f48efa241e826 (patch)
tree8334c835dcf3190510bdf69960d8fe77a2a6e3f6 /flake.nix
parent928d962b569154c96785d17c7cbcf45b0017d9cc (diff)
downloadnixos-fafc831d6be643ea184d117b2c8f48efa241e826.tar
nixos-fafc831d6be643ea184d117b2c8f48efa241e826.tar.gz
nixos-fafc831d6be643ea184d117b2c8f48efa241e826.tar.bz2
nixos-fafc831d6be643ea184d117b2c8f48efa241e826.tar.xz
nixos-fafc831d6be643ea184d117b2c8f48efa241e826.zip
...
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index f5008748..e380463b 100644
--- a/flake.nix
+++ b/flake.nix
@@ -44,7 +44,7 @@
44 inherit (nixpkgs) lib; 44 inherit (nixpkgs) lib;
45 utils = import ./utils { inherit lib; }; 45 utils = import ./utils { inherit lib; };
46 inherit (utils) nixImport overrideModule; 46 inherit (utils) nixImport overrideModule;
47 inherit (lib) nixosSystem mkIf splitString filterAttrs listToAttrs mapAttrsToList nameValuePair concatMap composeManyExtensions mapAttrs mapAttrs' recursiveUpdate genAttrs unique elem optionalAttrs isDerivation concatLists; 47 inherit (lib) nixosSystem mkIf splitString filterAttrs listToAttrs mapAttrsToList nameValuePair concatMap composeManyExtensions mapAttrs mapAttrs' recursiveUpdate genAttrs unique elem optionalAttrs isDerivation concatLists concatStringsSep;
48 48
49 accountUserName = accountName: 49 accountUserName = accountName:
50 let 50 let
@@ -210,6 +210,11 @@
210 filterEnabled = attrs: mapAttrs (_n: v: filterAttrs (n: _v: n != "enabled") v) (filterAttrs (_n: v: v.enabled or true) attrs); 210 filterEnabled = attrs: mapAttrs (_n: v: filterAttrs (n: _v: n != "enabled") v) (filterAttrs (_n: v: v.enabled or true) attrs);
211 in mapAttrs (_n: v: if v ? "profiles" then v // { profiles = filterEnabled v.profiles; } else v) (filterEnabled (recursiveUpdate defaults overrides)); 211 in mapAttrs (_n: v: if v ? "profiles" then v // { profiles = filterEnabled v.profiles; } else v) (filterEnabled (recursiveUpdate defaults overrides));
212 212
213 nixPath = forAllSystems (system: _: concatStringsSep ":" [
214 "nixpkgs=${nixpkgs.legacyPackages.${system}.path}"
215 "nixpkgs-overlays=${self.overlays-path.${system}}"
216 ]);
217
213 checks = builtins.mapAttrs (system: deployLib: deployLib.deployChecks self.deploy) deploy-rs.lib; 218 checks = builtins.mapAttrs (system: deployLib: deployLib.deployChecks self.deploy) deploy-rs.lib;
214 }; 219 };
215} 220}