summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorGregor Kleen <gkleen@yggdrasil.li>2022-03-13 10:41:41 +0100
committerGregor Kleen <gkleen@yggdrasil.li>2022-03-13 10:41:41 +0100
commit46152e140fe428538a562dcfd1627a88a02dcc09 (patch)
treebe9e750b58363bcde0749804681a2c5643883e2e /flake.nix
parentb4d952460bdd970d90e91d7b8e778b44a0ef3394 (diff)
downloadnixos-46152e140fe428538a562dcfd1627a88a02dcc09.tar
nixos-46152e140fe428538a562dcfd1627a88a02dcc09.tar.gz
nixos-46152e140fe428538a562dcfd1627a88a02dcc09.tar.bz2
nixos-46152e140fe428538a562dcfd1627a88a02dcc09.tar.xz
nixos-46152e140fe428538a562dcfd1627a88a02dcc09.zip
...
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 597ac14a..5e5e6d0d 100644
--- a/flake.nix
+++ b/flake.nix
@@ -136,6 +136,8 @@
136 packages = 136 packages =
137 let installerPackages = system: optionalAttrs (!(isNull installerConfig)) (mapAttrs' (profile: value: nameValuePair "installer-${profile}" value.output) installers.${system}); 137 let installerPackages = system: optionalAttrs (!(isNull installerConfig)) (mapAttrs' (profile: value: nameValuePair "installer-${profile}" value.output) installers.${system});
138 in forAllSystems (system: systemPkgs: self.overlays.default (self.legacyPackages.${system}) systemPkgs // installerPackages system); 138 in forAllSystems (system: systemPkgs: self.overlays.default (self.legacyPackages.${system}) systemPkgs // installerPackages system);
139
140 activateHomeManager = system: base: (deploy-rs.lib.${system}.activate.custom // { dryActivate = "DRY_RUN=1 $PROFILE/activate"; }) base.activationPackage "$PROFILE/activate";
139 in 141 in
140 { 142 {
141 nixosModules = 143 nixosModules =
@@ -183,7 +185,7 @@
183 }; 185 };
184 } // (mapAttrs (_user: usercfg: { 186 } // (mapAttrs (_user: usercfg: {
185 user = usercfg.home.username; 187 user = usercfg.home.username;
186 path = deploy-rs.lib.${self.nixosConfigurations.${hostname}.config.nixpkgs.system}.activate.home-manager usercfg.home; 188 path = activateHomeManager (self.nixosConfigurations.${hostname}.config.nixpkgs.system) usercfg.home;
187 }) self.nixosConfigurations.${hostname}.config.home-manager.users); 189 }) self.nixosConfigurations.${hostname}.config.home-manager.users);
188 }) (nixImport { dir = ./hosts; _import = (_path: name: name); }); 190 }) (nixImport { dir = ./hosts; _import = (_path: name: name); });
189 191